Jump to content

(solved) Armor and tools have no texture (1.8)


Wooden_Brick

Recommended Posts

When i open the game, the Tools and armor have no texture, even though i have the textures in my assets. I have other items and they work. does this method of making tools still work in 1.8?

 

 

public class TutorialItems {

 

public static Item test_item;

public static Item gem_1;

public static Item gem_pickaxe;

public static Item gem_helmet;

public static Item gem_chest;

public static Item gem_legs;

public static Item gem_boots;

 

public static final Item.ToolMaterial gemToolMaterial = EnumHelper.addToolMaterial("gemToolMaterial", 2, 512, 7.0F, 2.0F, 10);

public static final ItemArmor.ArmorMaterial gemArmorMaterial = EnumHelper.addArmorMaterial("gemArmorMaterial" , null, 1024,new int[]{5,9,7,5}, 30);

 

public static void init(){

test_item = new Item().setUnlocalizedName("test_item");

gem_1 = new Item().setUnlocalizedName("gem_1");

gem_pickaxe = new ItemGemPickaxe(gemToolMaterial).setUnlocalizedName("gem_pickaxe");

gem_helmet = new ItemGemArmor(gemArmorMaterial, 0, 0).setUnlocalizedName("gem_helmet");

gem_chest = new ItemGemArmor(gemArmorMaterial, 0, 1).setUnlocalizedName("gem_chest");

gem_legs = new ItemGemArmor(gemArmorMaterial, 0, 2).setUnlocalizedName("gem_legs");

gem_boots = new ItemGemArmor(gemArmorMaterial, 0, 3).setUnlocalizedName("gem_boots");

 

 

}

 

public static void register() {

GameRegistry.registerItem(test_item, test_item.getUnlocalizedName().substring(5)); //"tile.test_item"

GameRegistry.registerItem(gem_1, gem_1.getUnlocalizedName().substring(5));

GameRegistry.registerItem(gem_pickaxe, gem_pickaxe.getUnlocalizedName().substring(5));

GameRegistry.registerItem(gem_helmet, gem_helmet.getUnlocalizedName().substring(5));

GameRegistry.registerItem(gem_chest, gem_chest.getUnlocalizedName().substring(5));

GameRegistry.registerItem(gem_legs, gem_legs.getUnlocalizedName().substring(5));

GameRegistry.registerItem(gem_boots, gem_boots.getUnlocalizedName().substring(5));

 

}

 

public static void registerRenders() {

 

registerRender(test_item);

registerRender(gem_1);

registerRender(gem_pickaxe);

registerRender(gem_helmet);

registerRender(gem_chest);

registerRender(gem_legs);

registerRender(gem_boots);

 

}

 

the test_item and gem_1 textures work. This is the ItemGemPickaxe and ItemGemArmor classes:

 

package com.Babuska.items;

 

import net.minecraft.item.ItemArmor;

 

public class ItemGemArmor extends ItemArmor {

 

public ItemGemArmor(ArmorMaterial material, int renderIndex,

int armorType) {

super(material, renderIndex, armorType);

// TODO Auto-generated constructor stub

}

 

}

 

package com.Babuska.items;

 

import net.minecraft.item.ItemPickaxe;

 

public class ItemGemPickaxe extends ItemPickaxe {

 

public ItemGemPickaxe(ToolMaterial material) {

super(material);

 

}

 

 

}

 

Link to comment
Share on other sites

Main:

package com.Babuska;

 

import net.minecraftforge.fml.common.Mod;

import net.minecraftforge.fml.common.Mod.EventHandler;

import net.minecraftforge.fml.common.SidedProxy;

import net.minecraftforge.fml.common.event.FMLInitializationEvent;

import net.minecraftforge.fml.common.event.FMLPostInitializationEvent;

import net.minecraftforge.fml.common.event.FMLPreInitializationEvent;

import net.minecraftforge.fml.common.registry.GameRegistry;

 

import com.Babuska.init.TutorialBlocks;

import com.Babuska.init.TutorialItems;

import com.Babuska.proxy.CommonProxy;

 

 

@Mod(modid = References.MOD_ID, name = References.MOD_NAME, version = References.VERSION)

public class TutorialMod {

  @SidedProxy(clientSide = References.CLIENT_PROXY_CLASS, serverSide = References.SERVER_PROXY_CLASS)

      public static CommonProxy proxy;

 

  @EventHandler

  public void preInit(FMLPreInitializationEvent event){

      TutorialBlocks.init();

      TutorialBlocks.register();

     

      TutorialItems.init();

      TutorialItems.register();

TutorialItems.recipe();

  }

  @EventHandler

  public void init(FMLInitializationEvent event){

      proxy.registerRenders();

     

  } 

 

  @EventHandler

  public void postInit(FMLPostInitializationEvent event){

 

 

 

 

}

 

My json is a copy of a dmd pick/armor, with the name changed.

Link to comment
Share on other sites

 

public static void registerRender(Item item) {

 

  Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(item, 0, new ModelResourceLocation(References.MOD_ID + ":" + item.getUnlocalizedName().substring(5), "inventory"));

 

}

 

}

 

Ive been folowing tutorials, dont realy know what it does.

Link to comment
Share on other sites

{

    "parent": "builtin/generated",

    "textures": {

        "layer0": "items/gem_pickaxe"

    },

    "display": {

        "thirdperson": {

            "rotation": [ 0, 90, -35 ],

            "translation": [ 0, 1.25, -3.5 ],

            "scale": [ 0.85, 0.85, 0.85 ]

        },

        "firstperson": {

            "rotation": [ 0, -135, 25 ],

            "translation": [ 0, 4, 2 ],

            "scale": [ 1.7, 1.7, 1.7 ]

        }

    }

}

this is for gem_pickaxe.json

 

and by structure you mean this??

 

Assets.tm

          blockstates

          models

 

Link to comment
Share on other sites

Thank you diesieben07 for telling me to show jsons, only then i saw something:

 

"layer0": "items/gem_pickaxe"

 

and then i checked my gem item -

"layer0": "tm:items/gem_1"

and i noticed the tm: before items, i added that to the pickaxe and now it works :) so thank you :)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.