Jump to content

Items not rendering in Model after logging off


kitsushadow

Recommended Posts

I have a shelf block. When a player right clicks the shelf with an item or block it puts it in slot 0 and renders it like an itemFrame in the Shelf Model. If the the player has an empty hand and sneakClicks. It will pull the item out and give it to the player. Everything is fine and dandy up to this point. When the player logs off and then logs back in the item or block they put in the shelf doesn't render but when the player checks to see if there is an item by shift clicking. The item is pulled out and given to the player. If the player puts the item back in shelf everything starts working fine again.

 

Any Ideas with what the issue may be? Any help is welcome. If you'd like to see a particular class i can post it on pastebin no problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.