Jump to content

[1.7.10]Weird Forge Launching Behavior


BuddingDev

Recommended Posts

It is still happening till now.

 

When you are loading up the world, and if you are extremely unlucky to encounter this bug, the log tells you that you have entered a single-player world, but the GUI brings you back to the title screen.

Then when you tries to reload by re-entering the target world, the game unloads the world and loads it back! Usually you may be sent back to the original spawn-point...

Link to comment
Share on other sites

I know this behavior too. I think this should be on bug report.

(Or is this intended feature? I want to know)

 

Anyway, the mechanism would be in calling Minecraft#displayGuiScreen(null);

  while world is not loaded so Minecraft#theWorld is null.

I. Stellarium for Minecraft: Configurable Universe for Minecraft! (WIP)

II. Stellar Sky, Better Star Rendering&Sky Utility mod, had separated from Stellarium.

Link to comment
Share on other sites

It isnt any bug.

The logs still output normally, for example:

 

Loading world: How-many%

Player has joined the world

 

and then it brings me back.

So is it problem with your mod? Then you should describe what your mod does.

I. Stellarium for Minecraft: Configurable Universe for Minecraft! (WIP)

II. Stellar Sky, Better Star Rendering&Sky Utility mod, had separated from Stellarium.

Link to comment
Share on other sites

I'll just note that I too had this issue (on 1.8). In my dev - randomly (but seriously - it was like few times, 0.1% to happen).

I don't know why but I always felt like it was internet fault. Whenever that happened (very rare) - I was downloading something and had huge lag, almost couldnt login into game (mojang auth was taking about 10sec).

 

So just saying - it might be forge/mc fault.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.