Jump to content

[1.8] [solved] Books Invalid Book Tag


Recommended Posts

I've looked around and can't find anything on how to fix this.  It worked find in 1.7.2, but something must have changed for books.


The book is fine except for there is nothing on the pages but "*  Invalid book tag *"


Here is my code



    // Create the book

    ItemStack book = new ItemStack(Items.written_book);


    // Create NBT data and add to the book

    NBTTagList bookPages = new NBTTagList();

    bookPages.appendTag(new NBTTagString("This mod impliments wold control functionality and some player commands"));

    bookPages.appendTag(new NBTTagString("Commands are as follows Dimension_Manager(DM), ADVENTURE/SURVIVAL/CREATIVE, LAG, SKELETONHORSE(SH), SPAWN, SUMMONPLAYER, TELEPORTTO(TPTO)"));

    bookPages.appendTag(new NBTTagString("Custom Menu Items are as follows: none"));

    bookPages.appendTag(new NBTTagString("Permissions are as follows Dimension_Manager.All - Access to all, Dimension_Manager.lag - Lists Server Performance, Dimension_Manager.SkeletalHorse - Grants player a cool horse, Dimension_Manager.spawn - Brings player to server spawn, Dimension_Manager.summon - Summon another Player, Dimension_Manager.TPTO - Teleport to another Player"));

    book.setTagInfo("pages", bookPages);

    book.setTagInfo("author", new NBTTagString("delpi"));

    book.setTagInfo("title", new NBTTagString("ClanDoolittle DimensionManager Mod Instructions"));


    // Give the player the book





Interestingly enough, if I generate a writable book, the text shows up, but then it has a quill and all that.

Long time Bukkit & Forge Programmer

Happy to try and help

Link to comment
Share on other sites

Question on the debugger.


Since the code is in the minecraft library, I just go in and find the render part and toggle a breakpoint?


A second question for folks more experienced with debugging minecraft in eclipse, when i use the breakpoint, either the client or server crashes after about 5 seconds of one or the other being frozen.  Is there a better way to do that activity?

Long time Bukkit & Forge Programmer

Happy to try and help

Link to comment
Share on other sites

The debugger shouldn't make Minecraft crash. Can you post the crash log?


And yes, you can toggle a breakpoint in the vanilla jar

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.


1.12 -> 1.13 primer by williewillus.


1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.



Link to comment
Share on other sites

Yeh, that exactly describes what happens. 


I wonder if I grab the other side and pause it, if that would fix things?  Would have to be quick.  An automated way would be easier.


larsgerrits - I'll grab a snapshot of the log the next time it happens.





Long time Bukkit & Forge Programmer

Happy to try and help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.