Jump to content

[1.7.10] [Solved] Add custom recipe to Thermal Expansion machine


Niverton

Recommended Posts

Hello, I'm trying to add a smelting recipe to the Magma Crucible from TE, with  a custom item and a custom fluid. I've been looking for an answer for a few hours now, and I'm pretty sure it has something to do with CoFHLib's helpers, but I just can't find a solution. Much appreciated

Link to comment
Share on other sites

You need to send an IMC message to

"ThermalExpansion"

by calling

FMLInterModComms.sendMessage

before the postInit phase or

FMLInterModComms.sendRuntimeMessage

during the postInit phase. The reason you can use both methods is because TE subscribes to

IMCEvent

(fired between init and postInit) and also explicitly checks for runtime IMC messages when

FMLLoadCompleteEvent

fires (after postInit). Some mods only subscribe to

IMCEvent

, so they won't process runtime messages.

 

As far as I can tell there's no formal documentation of TE's expected IMC format, but you can download a recent dev version and view the

IMCHandler

class in a decompiler to see how it handles each message.

 

You'll need to use

ItemStack#writeToNBT

and

FluidStack#writeToNBT

to write the inputs and outputs to the NBT message you send to TE.

 

Edit: I forgot some words.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Thanks, it worked !

 

NBTTagCompound concreteRecipe = new NBTTagCompound();
concreteRecipe.setInteger("energy", 300);
concreteRecipe.setTag("input", (new ItemStack(concretePowder).writeToNBT(new NBTTagCompound())));
concreteRecipe.setTag("output", (new FluidStack(concreteFluid, 1000).writeToNBT(new NBTTagCompound())));
FMLInterModComms.sendMessage("ThermalExpansion", "CrucibleRecipe", concreteRecipe);

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hi I have an issue with a server it solved deleting the ice and fire but my friends and me really want to use it does any of these mods are causing the issue due to incompatibility  Security craft Aquaculture Architectury Artifacts Astikorcarts Baubles BetterCaves yungs BetterStrongholds yungs BetterMineshafts yungs Bountiful Byg  Callablehorses Carry on Chococraft Citadel Clumps Collective Comforts Corailrecycler Craftable horse armor Comes alive Curios forge Decocraft Dungeonsarise  Open blocks elevator Expandability Farlanders Goblin traders Hwyla  Ice and fire Infernal expansion Jei Jump over fences Mantle  Macaws bridges Macaws doors Macaws fences Macaws furniture  Macaws fencesbyg Morpheus Mouse tweaks Mowzies mobs Obfuscate Paraglider Patchouli  Pick up notifier Random village names Spartan shields Small ships Sophisticated backpacks Spartan weaponry Storage drawers straw golem Structure gel Twilight forest  Tinkers construct Two players one horse  Valhesia core  Valhesia structures  Way stones  Vehicle mod  Wall jump Wings Wolves with armor Xptome  Xaeros minimap  Yungsapi  
    • { "type": "magic_overhaul:rune_inscribing", "base": { "item": "//base item" }, "template": { "item": "//template item" }, "output": { "count": 1, "item": "//output item" } } ^ Ok, where is your recipe JSON placed in your file structure? What's it called? And paste the actual JSON you're testing with, because it needs to be valid.
    • I'm trying to run Forge 1.12.2 on Minecraft  so I can use certain mods, but this error popped up. I've seen multiple errors but I just can't figure this one out. Unable to locate the Java runtime. Error details: 0x00000000 - system: The operation completed successfully. Filename on disk:  Path: . Exists: Directory
    • https://mclo.gs/b422RFc
    • Плагин и Приват
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.