Jump to content

[1.6.4] Project files arent found by gradle on build - creates empty jar


Steven0320

Recommended Posts

Hello, I have been working on a mod, and I wanted to build it. I checked for and fixed all errors except an error with a bracket and semi colon that do not appear to cause problems in the game when I debug,  and I havent been able to fix them. At first I could not find the gradle files, I found on a website that I needed forge 1.6.4 build 964, and I downloaded it and it did have gradle. I copied the missing files, and when I runed gradlew.bat, it downloaded a few files and said Build Successful. Now when I use "gradle.build"  it downloads files and in build > lib i find an empty jar with my mod name and version that only contains MetaInf files.

 

The package name is: steven0320.varietymod

gradle files are in mcp118 > forge > mcp

Project files ae in mcp118 > forge > mcp > src > minecraft (assets are there, java files are in steven0320 folder)

 

Do I need to specify the location of my project files to gradle or configure anything before build, thanks.

Link to comment
Share on other sites

I tried compiling and get an error that says "cant find java compiler" and it says to check Java_Home system variable. I went and set the variable in the system variables for system not user, to the directory of JDK installation, and still doesnt work. Is there another way to compile, like compiling every jar using java compile in command prompt, then place the class files in the correct folder?

Link to comment
Share on other sites

I opened the gradlew.bat file with notepad++ and found a part that has to do with jdk.

It looks like this:

[embed=425,349]

 

:findJavaFromJavaHome

set JAVA_HOME=%JAVA_HOME:"=%

set JAVA_EXE=%JAVA_HOME%/bin/java.exe

 

[/embed]

I am going to try fixing the set java part and the java bin directory uses / shouldnt it be \?

 

edit:

Still doesnt work, im going to try restarting

Link to comment
Share on other sites

I forgot to place it under the load method.

 

 

Edit:

Still error on build.

Cannot find symbol.
symbol    :    method registerBlock(net.minecraft.block.Block)
location:   class cpw.mkds.fml.common.registry.GameRegistry
GameRegistry.registerBlock(enderblock);

Link to comment
Share on other sites

Anyone know what this could mean, I get this error when I run gradlew.bat, after it finishes I get build error and this error for every block I register.

 

my load method:

 


public void load(FMLInitializationEvent event) 
{
proxy.registerRenderInformation();

GameRegistry.registerBlock(juicemaker);
GameRegistry.registerBlock(sbjellyblock);
GameRegistry.registerBlock(blockMilkFluid);
GameRegistry.registerBlock(sbjellyblock);
GameRegistry.registerBlock(endertorch);
GameRegistry.registerBlock(caramelblock);
GameRegistry.registerBlock(stevepicture);
GameRegistry.registerBlock(enderblock);
   
   }

Link to comment
Share on other sites

I get this during compilation for every block, the error is the same only replacing enderblock with block name:

Cannot find symbol.
symbol    :    method registerBlock(net.minecraft.block.Block)
location:   class cpw.mkds.fml.common.registry.GameRegistry
GameRegistry.registerBlock(enderblock);

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello all! I'm currently trying to make the Biomes o' Plenty mod (1.12.2 version) compatible with my shaderpack (BSL v8.5). Even after I've already inserted a "shaders" folder with a correctly-formatted blocks.PROPERTIES file within the assets folder of the .jar, it still does not wave the textures from the mod. I definitely thought this was going to work since I noticed the 1.19.2 version of the mod laid it out exactly like that and it worked perfectly when my PC was able to run 1.19.2 Forge... ^^;;; Could there be some missing link I'm not getting at here?
    • After much experimentation I finally realised why this doesn't work and how to fix it. The critical component to understand here, is that ItemCraftedEvent is called before the crafting ingredients are purged from the crafting slots; this all happens in ResultSlot.java's onTake method: We can see here the first line fires checkTakeAchievements, this is what fires the ItemCraftedEvent (after a few method calls). Then we can see the purge behaviour. I worked around this by creating a CarverItem class, which uses hasCraftingRemainingItem and getCraftingRemainingItem to hook into ResultSlot.onTake: Now, I reconstruct my ItemCraftedEvent handler, and using some smart tags (which I omit for brevity), I handle two cases: 1. When crafting a carved item, I damage the tool used in the recipe 2. When crafting a carving tool from a repair recipe, I manually purge the input tools as with the new CarverItem class, as otherwise items would be duplicated   This has now greatly improved implementation, beyond my expectations, for the standard crafting table and the user's inventory crafting grid. A user can now click or shift-click 'carve' items, with no duplication or issues that I have spotted so far.  
    • Hi, I'm having issues launching my Forge 1.20.1 installation (47.2.0). I keep getting error code 1, and all the logs abruptly pause with the game attempting to open GL 4.6. Latest Crash: https://pastebin.com/zsP5Wipk Debug (No idea what the real name is) Log: https://pastebin.com/CzvqhNq0   Thanks for the help!
    • In the most up to date version of Allthemods 6 (v1.9.2) the stoned bee is not able to be interacted with apart from putting it into an empty bee jar. I can't breed the bee or put it into my aviary breeder. When I try to put it into the breeder it says import unsuccessful. The stoned bee is one of the most important bees for advancing in the mod so it is rather unfortunate that it is not working as intended.
    • Everytime I try to run the Forge 1.20.1 - 47.1.0 Installer, only appears an a black window and then closes. I don't appear the installing menu anymore.
  • Topics

  • Who's Online (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.