Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Problem running final mod due to lib dependancies


big_red_frog
 Share

Recommended Posts

Hi all,

 

Unfortunately I am not a java expert, but generally software aware. I have a fully functional mod when building / running from eclipse. I have a set of specific jar libs that I had to add as external dependancies for some websocket behaviour. I did this via Java Build Path \ libraries.

 

Everything there builds and runs fine.

 

I am in the final steps of wanting to be able to just provide a final jar file, dropping it in the mod folder of a minecraft installation and all magically working.

 

However, using the "gradlew build" method from the command line to generate my final jar file, the libs required are not resolved at run time in a clean minecraft installation ( even on the same machine ) so I get not found errors.

 

I have these in my gradle.build

 

dependencies {

compile 'org.eclipse.jetty.websocket:websocket-api:9.3.5.v20151012'

compile 'org.eclipse.jetty.websocket:websocket-client:9.3.5.v20151012'

compile 'org.eclipse.jetty.websocket:websocket-common:9.3.5.v20151012'

}

 

I have also tried having them directly in the libs directory and it also builds fine, but at runtime I always get the following error...

 

java.lang.NoClassDefFoundError: org/eclipse/jetty/websocket/client/WebSocketClient

 

How do I encapsulate these jar libs into my mod so they can be found at runtime....

 

Any help greatly appreciated, been trying to resolve this for a while now. I would settle for knowing where I can drop copies of the libs so it just runs right now :-(

 

[14:27:02] [main/INFO] [FML]: Forge Mod Loader version 8.99.124.1450 for Minecraft 1.8 loading

-- System Details --

Details:

 

Minecraft Version: 1.8

Operating System: Windows 10 (amd64) version 10.0

Java Version: 1.8.0_25, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

 

[14:27:11] [Client thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization

[14:27:11] [Client thread/INFO] [FML]: MinecraftForge v11.14.3.1450 Initialized

 

 

[14:29:22] [server thread/ERROR] [FML]: The following problems were captured during this phase

[14:29:22] [server thread/ERROR] [FML]: Caught exception from myModsId

java.lang.NoClassDefFoundError: org/eclipse/jetty/websocket/client/WebSocketClient

at org.dev0xx4kids.forge.mods.AttachNimbus.<init>(AttachNimbus.java:34) ~[AttachNimbus.class:?]

at org.dev0xx4kids.forge.mods.Main.registerCommands(Main.java:32) ~[Main.class:?]

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_25]

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_25]

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~

Link to comment
Share on other sites

Huge thanks, once I had realized that shading was a built in behavior rather than a plugin, and managed to interpret the instructions ( and get them at the end of my gradlew.build file ) then everything just works. I had been down many dead ends before this.

 

My head thanks you! It was getting bruised with all the wall banging it had been doing!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.