Jump to content

[1.7.10] Problem adding recipes - ClassCastException


ax1m

Recommended Posts

I'm trying to modularize the way I add recipes to my mod, in order to cut down on all the duplicate code I've been writing. I've seen examples around the internet of people using an Object array to pass crafting pattern and ingredients, but for some reason I can't get it to work, as it keeps crashing on startup.

 

Here's the code where it crashes:

package ch.ax1m.aximtech.init;

// SNIP - imports

public class Recipes {

    // SNIP - init method and other stuff

    private static void addToolRecipe(ItemToolAT tool) {

        String mat = tool.getOreMaterial();
        Object[] pattern = null;

        switch(Reference.ToolData.toolTypes.indexOf(tool.getToolType())) {
            case 0:
                pattern = new Object[] { "hXf", " X ", " I ", 'h', "hammer", 'f', "file" };
                break;

            // SNIP - other tool types

        }
        GameRegistry.addRecipe(new ShapedOreRecipe(new ItemStack(tool), pattern,
                'X', "ingot" + mat, 'P', "plate" + mat, 'R', "rod" + mat, 'I', "stickWood"));
    }
}

 

And this is the top of the stacktrace:

java.lang.ClassCastException: [Ljava.lang.Object; cannot be cast to java.lang.Character
at net.minecraftforge.oredict.ShapedOreRecipe.<init>(ShapedOreRecipe.java:89)
at ch.ax1m.aximtech.init.Recipes.addToolRecipe(Recipes.java:110)
at ch.ax1m.aximtech.init.Recipes.init(Recipes.java:42)
at ch.ax1m.aximtech.AximTech.init(AximTech.java:46)

 

I also tried wrapping the chars in my pattern Object in Character.valueOf(), as I've seen in a couple examples, but that didn't change anything, still gives me the same error.

Link to comment
Share on other sites

ShapedOreRecipe

expects the pattern to be 1-3 strings or an array of strings, you're passing an array of pattern strings and ingredients.

 

You need to concatenate the pattern/ingredient array with the other ingredients.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Sorry if this is a really noobish question, but how would I go about declaring an array with alternating char and String type elements?

 

If you need a collection to store multiple types, you need to declare it using a common parent of those types.

String

and

Character

don't have any common parent apart from

Object

, so declare it as an array of

Object

s.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

But that's what I'm trying to do already, so wouldn't that just get me right back to not being able to cast an Object to a char?

 

That's not the issue here.

 

You're passing an

Object

array containing the pattern strings and some of the ingredients followed by the rest of the ingredients, so essentially you end up with this:

new ShapedOreRecipe(new ItemStack(tool), new Object[]{ "hXf", " X ", " I ", 'h', "hammer", 'f', "file" }, 'X', "ingot" + mat, 'P', "plate" + mat, 'R', "rod" + mat, 'I', "stickWood")

 

What you want is this (every argument except the first will be wrapped in an array because this is a vararg method):

new ShapedOreRecipe(new ItemStack(tool), "hXf", " X ", " I ", 'h', "hammer", 'f', "file", 'X', "ingot" + mat, 'P', "plate" + mat, 'R', "rod" + mat, 'I', "stickWood")

 

You need to create a single array containing all the pattern strings and ingredients and pass that as the second argument of the constructor.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.