Jump to content

[1.7.10] Eclipse: " It is indirectly referenced from required .class file"


NickDP

Recommended Posts

Hello :)

 

Im very new to all this minecraft modding, but the other day i thought i'd give it a go.

 

But i ran into a problem when i was setting up the development enviroment in eclipse. Now the issue is that, when ever i try to use the "getHandle()", method on any Entitys eclipse just says "The type yv cannot be resolved. It is indirectly referenced from required .class files"

 

public SkillResult use(Hero hero, LivingEntity target, String[] args) {
    	Player player = hero.getPlayer();
    	CraftVillager liv = (CraftVillager)target;
    	liv.getHandle(); <-- "The type yv cannot be resolved. It is indirectly referenced from required .class files"
}

 

I've been searching all over the damn net, but i cant seem to find any post regarding this issue. I suppose its something with the referenced libraries, but i cant seem to find the issue :/

 

Hope you guys can help me out!

 

Best regards

Nick

 

 

For clarification:

azS2zUv.png

Link to comment
Share on other sites

you need to check the target class before you cast it and call a non-overridden method.

 

if( target instanceof CraftVillager)

 

Ah yes, im aware :)

 

Issue isent the code, but the "setup" in eclipse, that somehow breaks the references to what ever classes "getHandle()" uses :/

Link to comment
Share on other sites

CraftVillager? getHandle? This sounds like bukkit.

What the hell are you doing? :D

 

Aww hell man, you're totaly right >.<

 

I was somehow thinking that since i followed the "setup" here on Forge, the error might something that could be addressed here.

 

But as you point out, getHandle is ofcourse from bukkit

Link to comment
Share on other sites

Forge + Sponge API is the future.

 

As to other:

* Spigot (please don't).

* Glowstone (Idk, Sponge is stil better).

* Some other, mostly dead or soon-to-be-dead like: MCPC, Cauldron, Bukkit - all of those are officialy dead and only privately updated by some random ppl.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.