Jump to content

[1.9 and 1.8] Compiling Mod


NovaViper

Recommended Posts

How do I compile my mod? I tried build but I can't seem to locate the of the jar file also I get this: (This is in 1.9)

 

09:34:42 AM: Executing external task 'build'...
Timeout waiting to connect to the Gradle daemon.
Daemon uid: 46c00c9f-beb1-4976-bba3-15eb7adb74c6 with diagnostics:
Daemon pid: 1300
  log file: C:\Users\NovaPC\.gradle\daemon\2.7\daemon-1300.out.log
----- Last  20 lines from daemon log file - daemon-1300.out.log -----
09:36:21.586 [LIFECYCLE] [org.gradle.launcher.daemon.server.Daemon] Daemon server started.
09:36:21.593 [DEBUG] [org.gradle.launcher.daemon.bootstrap.DaemonStartupCommunication] Completed writing the daemon greeting. Closing streams...
09:36:21.596 [DEBUG] [org.gradle.launcher.daemon.server.Daemon] requestStopOnIdleTimeout(60000 MILLISECONDS) called on daemon
09:36:21.596 [DEBUG] [org.gradle.launcher.daemon.server.DaemonStateCoordinator] Idle timeout: waiting for daemon to stop or be idle for 60000ms
09:36:21.603 [DEBUG] [org.gradle.launcher.daemon.server.DaemonStateCoordinator] Idle timeout: daemon has been idle for requested period. Stopping now.
09:36:21.605 [DEBUG] [org.gradle.launcher.daemon.server.DaemonStateCoordinator] Marking daemon stopped due to idle timeout. The daemon is running a build: false
09:36:21.605 [DEBUG] [org.gradle.launcher.daemon.server.Daemon] stop() called on daemon
09:36:21.606 [iNFO] [org.gradle.launcher.daemon.server.Daemon] Stop requested. Daemon is removing its presence from the registry...
09:36:21.608 [DEBUG] [org.gradle.launcher.daemon.server.DomainRegistryUpdater] Removing our presence to clients, eg. removing this address from the registry: [d936cc49-b7b1-4e47-8cc4-b3a33855a594 port:54148, addresses:[/127.0.0.1, /0:0:0:0:0:0:0:1]]
09:36:21.609 [DEBUG] [org.gradle.launcher.daemon.registry.PersistentDaemonRegistry] Removing daemon address: [d936cc49-b7b1-4e47-8cc4-b3a33855a594 port:54148, addresses:[/127.0.0.1, /0:0:0:0:0:0:0:1]]
09:36:21.748 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire exclusive lock on daemon addresses registry.
09:36:21.750 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acquired.
09:36:21.784 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Releasing lock on daemon addresses registry.
09:36:21.786 [DEBUG] [org.gradle.launcher.daemon.server.DomainRegistryUpdater] Address removed from registry.
Daemon vm is shutting down... The daemon has exited normally or was terminated in response to a user interrupt.
09:36:21.869 [DEBUG] [org.gradle.launcher.daemon.registry.PersistentDaemonRegistry] Removing daemon address: [d936cc49-b7b1-4e47-8cc4-b3a33855a594 port:54148, addresses:[/127.0.0.1, /0:0:0:0:0:0:0:1]]
09:36:21.876 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire exclusive lock on daemon addresses registry.
09:36:21.877 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] The file lock is held by a different Gradle process. I was unable to read on which port the owner listens for lock access requests.
09:36:22.079 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acquired.
09:36:22.101 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Releasing lock on daemon addresses registry.
----- End of the daemon log -----

09:36:51 AM: External task execution finished 'build'.

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

It looks like the Gradle daemon is having problems, try running

gradlew build

with the daemon disabled, as described here.

 

I tried running

gradlew build

and tried

build --no-daemon

but Gradle says that it that gradlew does not exist and that it does not know --no-daemon

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

Also I tried running

build

again and I get this now:

 

03:50:56 PM: Executing external task 'build'...
:deobfCompileDummyTask
:deobfProvidedDummyTask
:sourceApiJava UP-TO-DATE
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
warning: [options] bootstrap class path not set in conjunction with -source 1.6
C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build\sources\main\java\novaviper\tetracraft\common\command\CommandTetraCraft.java:113: error: diamond operator is not supported in -source 1.6
	private final Map<String, ICommand> orderedCommandMap = new LinkedHashMap<>();
	                                                                          ^
  (use -source 7 or higher to enable diamond operator)
C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build\sources\main\java\novaviper\tetracraft\common\item\ItemModBow.java:122: error: method references are not supported in -source 1.6
	boolean hasAmmo = findAmmoSlot(shooter, this::isArrow) != null;
	                                              ^
  (use -source 8 or higher to enable method references)
C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build\sources\main\java\novaviper\tetracraft\common\item\ItemModBow.java:128: error: diamond operator is not supported in -source 1.6
		return new ActionResult<>(EnumActionResult.FAIL, bow);
		                        ^
  (use -source 7 or higher to enable diamond operator)
C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build\sources\main\java\novaviper\tetracraft\lib\Registers.java:55: error: diamond operator is not supported in -source 1.6
public static final Set<Item> items = new HashSet<>();
                                                  ^
  (use -source 7 or higher to enable diamond operator)
C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build\sources\main\java\novaviper\tetracraft\lib\Registers.java:111: error: method references are not supported in -source 1.6
	return addBlock(block, ItemBlock::new);
	                                  ^
  (use -source 8 or higher to enable method references)
5 errors
1 warning
:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 17.85 secs
Compilation failed; see the compiler error output for details.
03:51:14 PM: External task execution finished 'build'.

 

I already switched the source to 1.8 but it looks like its not saving. I'm using the latest version of IntelliJ

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

Where do I put this line that? I placed in at the top of the file and I get this error from Gradle:

 

07:32:44 PM: Executing external task 'build'...

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\Users\NovaPC\Dropbox\MinecraftMods\TetraCraft\1.9\build.gradle' line: 1

* What went wrong:
A problem occurred evaluating root project '1.9'.
> No such property: sourceCompatibility for class: org.gradle.api.internal.project.DefaultProject_Decorated

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 14.72 secs
No such property: sourceCompatibility for class: org.gradle.api.internal.project.DefaultProject_Decorated
07:33:00 PM: External task execution finished 'build'.

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

You need to add the

srcCompat

and

targetCompat

(not

sourceCompatibility

and

targetCompatibility

) properties in the main body of build.gradle, after the

buildscript

and

plugins

blocks.

 

You can see an example of this here.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

You need to add the

srcCompat

and

targetCompat

(not

sourceCompatibility

and

targetCompatibility

) properties in the main body of build.gradle, after the

buildscript

and

plugins

blocks.

 

You can see an example of this here.

 

Thanks Choonster! The compiled mod is the file that doesn't say source right?

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

Thanks Choonster! The compiled mod is the file that doesn't say source right?

 

Yes, the JAR without a suffix is the compiled mod.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.