Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.9]Mod shows up in game, but not on server


baiomu
 Share

Recommended Posts

So after finally figuring out how to compile my test mod, it works perfectly on the client, blocks, generation, items, etc. using forge 1.9 - 12.16.1.1887.

 

Sadly, when I install forge on a server, and then add the mod .jar to the file, it loads the mod during startup - no errors. nothing out of the ordinary. sadly, no items are showing up. using /give does nothing because i cannot use the modid, there is only minecraft:x. no items, blocks, or anything show up in the creative menu, yet if i quit out of the server, and go into singleplayer, they're there. if i try to connect without the mod, it boots me and says i need it.

 

this was tested on a computer hosting the server, connecting to it, and a remote computer connecting to it with the mods. the remote computer also has no problems in singleplayer.

 

tried it with and without the -sources jar in with it, too. same problem.

 

log of one startup - http://pastebin.com/imhdwPG5

 

mod in question - http://www.mediafire.com/download/ekrpykru96m43xb/tm-1.0%282%29.jar

 

files before compiling - http://www.mediafire.com/download/43d6gw2hlzmv0li/minecraftmod.rar

ayyyyyyyyy

Link to comment
Share on other sites

Your mod does precisely nothing on a dedicated server since your "Common"Proxy (it's not really common... it's the server proxy) does precisely nothing.

 

how do i fix it?

 

fixed it. thank you.

ayyyyyyyyy

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.