Jump to content

[Solved][1.9.4] Placed block is invisible


mmdanggg2

Recommended Posts

I am trying to update my mod into 1.9 and have sorted through all the errors and now, after getting in game, one of my blocks is not rendering at all.

 

lX47LIX.png

 

As you can see the block, when placed, is not there. However the item for the block is displaying as intended.

 

blockstates/miningRig.json:

{
    "variants": {
        "facing=north": { "model": "doge:miningRig" },
        "facing=south": { "model": "doge:miningRig", "y": 180 },
        "facing=west":  { "model": "doge:miningRig", "y": 270 },
        "facing=east":  { "model": "doge:miningRig", "y": 90 }
    }
}

 

models/block/miningRig.json:

{
    "parent": "block/cube",
    "textures": {
        "particle": "doge:blocks/miningRigFrontOff",
        "up": "doge:blocks/miningRigTopBackOff",
        "down": "doge:blocks/miningRigBottom",
        "south": "doge:blocks/miningRigTopBackOff",
        "north": "doge:blocks/miningRigFrontOff",
        "east": "doge:blocks/miningRigSideOff",
        "west": "doge:blocks/miningRigSideOff"
    }
}

 

models/items/miningRig.json:

{
    "parent": "doge:block/miningRig"
}

 

models registered with:

ModelLoader.setCustomModelResourceLocation(Item.getItemFromBlock(Doge.miningRig), 0, new ModelResourceLocation(Doge.miningRig.getRegistryName(), "inventory"));

 

The other block I have is working fine although it has no block states and simply uses block/cube_all model

 

full source available here: https://github.com/mmdanggg2/DogeMod/tree/1.9.4

I have a youtube if you care:

https://www.youtube.com/c/mmdanggg2

Link to comment
Share on other sites

BlockContainer

overrides

Block#getRenderType

to return

EnumBlockRenderType.INVISIBLE

, which prevents the standard baked model from being rendered (so the model can be rendered by a

TESR

).

 

You could override

Block#getRenderType

to return

EnumBlockRenderType.MODEL

(like various vanilla blocks with

TileEntities

do), but the best way around this is to not extend

BlockContainer

at all. Instead, override

Block#hasTileEntity(IBlockState)

and

Block#createTileEntity

.

 

MiningRig

has a

getRenderType

method returning 3, but this no longer overrides

Block#getRenderType

in 1.9+. Always annotate override methods with

@Override

. If this gives you a compilation error, fix the method signature rather than removing the annotation.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Exception in thread "main" java.lang.IllegalStateException: Current Java is 1.8.0_271 but we require at least 17         at net.minecraftforge.bootstrap.shim.Main.main(Main.java:32) Never have successfully gotten a minecraft server up and running so I thought i'd try again. Instant unfixable issue.  
    • What MC version? What's the IP? Are any mods needed to be able to join?
    • Thank you for your answer ! Unfortunatly i have the same problem when i use setPos() public static int movingfunction(CommandContext<CommandSourceStack> context){ CommandSourceStack source = context.getSource(); if (!(source.getEntity() instanceof ServerPlayer)) { return 0; } ServerPlayer player = (ServerPlayer ) source.getEntity(); double moveSpeed = 0.5; for (int i =0; i<10000;i++) { LOGGER.info("running for the {} time", i); double x = player.getX() + player.getViewVector(1.0f).x * moveSpeed; double y = player.getY(); double z = player.getZ() + player.getViewVector(1.0f).z * moveSpeed ; Vec3 movementVec = new Vec3(x, y, z); LOGGER.info("x ={} y ={} z ={}", x, y, z); player.setPos( movementVec); } return 1; } With the logs i can see that x and z are increasing but once again my player is not moving. is there a function to use to sync the server and the client ? I also tried to use LocalPlayer instead of ServerPlayer but my code would stop when i got the object. Also i will change a bit the main topic but is there a way to similate key press ? i found KeyBinding.setKeyBindState on others post but it look like there is no more KeyBinding in 1.20   I found this code : KeyMapping.click(Minecraft.getInstance().options.keyUp.getKey()); But it doesn't seems to work   And i found this one : Minecraft.getInstance().options.keyUp.setDown(true); wich works but doesn't exactly do what i want , it doesn't release the key so for exemple i can't make him run. Minecraft.getInstance().options.keyUp.setDown(true); Minecraft.getInstance().options.keyUp.setDown(false); Minecraft.getInstance().options.keyUp.setDown(true); doesn't make him run
    • Add crash-reports with sites like https://paste.ee/ Maybe an issue with blur, essentials or cumulus_menus
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.