Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge Gradle RAM Shortages for Decomp


LegoF4
 Share

Recommended Posts

While attempting to install the latest version of MC Forge, I came upon a well documented failure, whereby the Gradle installer possessed insufficient memory to decompileMc.

After researching various previously reported errors, such as #324 on github, as well as checking the documentation,  I failed to correct the issue. I have created a file named "gradle.properties", saved using UTF8 and alternately located within my Forge src directory and ~/.grade/, containing the line: "org.gradle.jvmargs=-Xmx3G", but to no avail. Throughout this process gradle RAM usage did not exceed 512Mb, despite my efforts to the contrary. My computer posses 8 GB RAM. My logs can be found here , I hope someone here can guide me through a solution. Thanks in advance for your help, hope I did not miss anything obvious.

Link to comment
Share on other sites

Upon further investigation I discovered a partial solution:

By first setting the environment variable "GRADLE_OPTS" to "-Xmx1024M" through the command: "set GRADLE_OPTS=-Xmx1024M" I was able to complete the decompilation process, however it took upwards of 20 minutes.

When attempting to assign more RAM to Gradle, I received the following error:

Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap

Link to comment
Share on other sites

I am unsure as to how to do so, being extremely unfamiliar with the console.

Additionally, I have already successfully installed the forge MDK. I am simply leaving this thread open in hopes of a solution being found for future reference.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.