Jump to content

[1.10] Custom model issues


wesserboy

Recommended Posts

Hello everyone,

 

For my mod I am making some kind of pedestal that can hold an item, it looks like this:

 

width=800 height=449https://s31.postimg.org/6c0glhp3f/2016_07_12_17_05_22.png[/img]

 

I am using a json model file to render the base, and a TileEntitySpecialRenderer for the pillars and the item.

The model is rendering correctly, however there are still some minor details that are not working correctly:

 

#1:

Probably the easiest one (I think). The block-break particles show up as missing texture. After reading numerous forum posts my friend Google kindly provided me it seemed like the problem always was the missing "particle" element in the json model. Adding this element did however not fix the problem for me. I suspect the problem might be because i am also using a TileEntitySpecialRenderer, but i couldn't find a solution.

this is my json model:

https://gist.github.com/wesserboy/26c88e64bafa39c7204bb36421e7b8c5

SOLVED, see 2nd post for the answer

 

 

#2:

The bounding box for my model is behaving very strange.

Since my model is not occupying the full block space i wanted to set up a custom bounding box. I used the following code to do this:

 

protected static final AxisAlignedBB AABB = new AxisAlignedBB(0.125D, 0.0D, 0.125D, 0.875D, 0.5D, 0.875D);

@Override
public AxisAlignedBB getBoundingBox(IBlockState state, IBlockAccess source, BlockPos pos) {
	return AABB;
}

 

As you can see in the first picture the wireframe shows up the way i expected, and from the top the bounding box acts the same as the one form the slab (The box has the same height), because the player auto-walks on top of it. However when i stand one level below the block (face the same level as the block) and i walk into the block i get the following screen:

 

width=800 height=449https://s31.postimg.org/yq5w5dcnf/2016_07_12_17_06_02.png[/img]

 

If i am in survival mode the player also takes damage (suffocation). This leads me to believe that the problem lies in the collision box, however i have no idea how to solve this.

SOLVED, see 2nd post for the answer

 

 

#3 (Bonus issue)

I am currently rendering the pillars by rendering obsidian using the RenderItem and scaling this to look like pillars. This is obviously not the correct way of doing things, but i wasn't able to find a way to animate certain parts of a json model using the TileEntitySpecialRenderer. If anyone knows how to properly do this, be sure to let me know.

 

 

Any help would be much appreciated! :)

If more code is needed, just ask and i will provide it.

I made the Mob Particles mod, you can check it out here: http://www.minecraftforum.net/topic/2709242-172-forge-mob-particles/

Link to comment
Share on other sites

UPDATE:

 

Problem #1 is magically solved  ???. I suspect that the problem was indeed the "particle" element missing and i probably just forgot to save the file somewhere along the line....... oops  :-[

 

Problem #2 is also solved. I solved it by overriding isFullCube to return false (seems obvious now  :-\). I also found the isFullBlock method, should i override this as well? Because it feels to me that these two methods are basically the same thing. (Correct me if i'm wrong)

I made the Mob Particles mod, you can check it out here: http://www.minecraftforum.net/topic/2709242-172-forge-mob-particles/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.