Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

json, block rotation and all these things.


salvestrom
 Share

Recommended Posts

updating from 1.7.10 to 1.9.4, i had/have 4 blocks with 16 point rotational placement, like skulls, banners etc.. advised to move away from tesr's for such things I encountered some challenges. the first is that blockstate jsons only recognise angles in multiples of 90. In order to get to 16, i had to create 4 block model files in which the skull element would be given an additional rotation, which is limited to being 22.5, 45, 0, -22.5, and 45.

 

So, my 16 rotation variants are grouped into 4s, each group specifying rotations of 0, 90, 180 and 270  for 4 different models, that apply element rotations of 22.5, 0, -22.5 and 45.

 

It isn't surprising that skulls are still handled by tesrs in vanilla.

 

Is there another option. Will an obj model avoid both the tesr and the json?

Link to comment
Share on other sites

This, at least, doesn't work, as the Forge class also makes the call to ModelRotation which is where the  90 increments are hard coded. is there a tag i should be using instead of "y" ?

 

 

{

  "forge_marker": 1,

  "variants": {

    "rotation=0": { "model": "thejungle:ancientSkull" },

    "rotation=8": {"model": "thejungle:ancientSkull", "y": 180},

 

    "rotation=9": {"model": "thejungle:ancientSkull", "y": -202.5},

    "rotation=13": {"model": "thejungle:ancientSkull", "y": -292.5},

 

//snipped

   

 

 

i was unable to match the syntax used in the documentation. eg " "rotation": { 0: { stuff here "produced an error.

Link to comment
Share on other sites

    "rotation=1": { "model": "thejungle:ancientSkull", "transform": {"rotation": {"y": -22.5}}},

 

the above rotates and grows/shrinks the textures, depending on the block face, which is weird as well as unhelpful.

i've tried leaving out the transform tag and/or using post-rotation instead of rotation, but that accomplishes nothing.

there are no errors in the json, or in the console. textures are currently being handled in the model file.

 

Link to comment
Share on other sites

ZQCX2HT.png

 

its as if the rotation is being applied, but the texture doesnt know how to apply to the "angled" surface and stays at right angles. this suggests i'm missing something related to textures but i cant find any indication that changes are required in the block model file and none of the syntax variations ive tried have worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.