Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge Error


gamerzwin
 Share

Recommended Posts

I have tried this now like 10 times and I keep getting the same error and it is getting on my nerves. Can anyone help here is the code:

================ Forge ModLoader Setup Start ===================
Downloaded mcp7.25.zip
Extracting MCP to 'C:\Users\NotTelling\Desktop\Programming\forge\mcp'
Setting up MCP
Backing up commands.py
patching file commands.py
Commands patch applied successfully
Copying FML conf
Creating re-packaged srg
Creating re-packaged exc
Creating re-packaged MCP patch
Fixing MCP Workspace
Downloaded argo-2.25.jar
Downloaded guava-12.0.1.jar
Downloaded guava-12.0.1-sources.jar
Downloaded asm-all-4.0.jar
Downloaded asm-all-4.0-source.jar
Downloaded bcprov-jdk15on-147.jar
Downloaded lwjgl.jar
Downloaded lwjgl_util.jar
Downloaded jinput.jar
Downloaded windows_natives.jar
    Extracting jinput-dx8.dll
    Extracting jinput-dx8_64.dll
    Extracting jinput-raw.dll
    Extracting jinput-raw_64.dll
    Extracting lwjgl.dll
    Extracting lwjgl64.dll
    Extracting OpenAL32.dll
    Extracting OpenAL64.dll
Downloaded macosx_natives.jar
    Extracting libjinput-osx.jnilib
    Extracting liblwjgl.jnilib
    Extracting libopenal.dylib
    Extracting openal.dylib
Downloaded linux_natives.jar
    Extracting libjinput-linux.so
    Extracting libjinput-linux64.so
    Extracting liblwjgl.so
    Extracting liblwjgl64.so
    Extracting libopenal.so
    Extracting libopenal64.so
Downloaded minecraft.jar
Downloaded minecraft_server.jar
== MCP 7.25 (data: 7.25, client: 1.4.6, server: 1.4.6) ==
# found ff, ff patches, srgs, name csvs, doc csvs, param csvs, renumber csv, ast
yle, astyle config
> Creating Retroguard config files
== Decompiling client using fernflower ==
> Creating SRGs
> Applying Retroguard
> Compiling AccessTransformer
> Compiling MCPMerger
> Running MCPMerger
> Running AccessTransformer
   Forge config detected
> Really Applying Retroguard
> Applying MCInjector
> Unpacking jar
> Copying classes
> Decompiling
> Copying sources
> Applying fernflower fixes
> Applying patches
> Cleaning comments
- Done in 149.71 seconds
== Reformating client ==
> Cleaning sources
FATAL ERROR
Traceback (most recent call last):
  File "C:\Users\Alexander\Desktop\Programming\forge\mcp\runtime\decompile.py",
line 116, in decompile
    strip_comments=strip_comments, exc_update=exc_update)
  File "C:\Users\Alexander\Desktop\Programming\forge\mcp\runtime\mcp.py", line 6
8, in decompile_side
    reformat_side(commands, side)
  File "C:\Users\Alexander\Desktop\Programming\forge\mcp\runtime\mcp.py", line 8
4, in reformat_side
    commands.process_cleanup(side)
  File "C:\Users\Alexander\Desktop\Programming\forge\mcp\runtime\commands.py", l
ine 1338, in process_cleanup
    src_cleanup(pathsrclk[side], fix_imports=True, fix_unicode=True, fix_charval
=True, fix_pi=True, fix_round=False)
  File "C:\Users\Alexander\Desktop\Programming\forge\mcp\runtime\pylibs\cleanup_
src.py", line 256, in src_cleanup
    shutil.move(tmp_file, src_file)
  File "shutil.pyc", line 300, in move
WindowsError: [Error 32] The process cannot access the file because it is being
used by another process: 'src\\minecraft\\net\\minecraft\\world\\IBlockAccess.ja
va.tmp'
Decompile Exception: 1
Press any key to continue . . .

 

 

Help would be greatly appreciated!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.