Jump to content

[1.10.2] Block specific id's...?


Leomelonseeds

Recommended Posts

So im planning to make a block(tileentity) with a gui that allows you to set a specific id for the block(1, 2, 3...) that teleports you to the nearest block with the same id. How would I go about storing that id variable?

Apparently I'm addicted to these forums and can't help but read all the posts. So if I somehow help you, please click the "Like This" button, it helps.

Link to comment
Share on other sites

You shouldn't use IDs, as those may not be the same every time you use them. You should either store a Block/IBlockState instance, and save the registry key/metadata to NBT when you need to. Why did you want to use IDs over anything else in the first place?

  • Like 1

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

13 minutes ago, Leomelonseeds said:

So im planning to make a block(tileentity) with a gui that allows you to set a specific id for the block(1, 2, 3...) that teleports you to the nearest block with the same id. How would I go about storing that id variable?

 

Use World Capabilities or World Saved Data, either per-map or per-dimension as needed.

 

You can see how RFTools stores its telerporter destinations here.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Just to clear things up a bit: if with IDs you Block IDs, use my suggestion. If you were talking about your own IDs like RFTools, use Choonster's suggestion.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.