Jump to content

[1.7.10] Obfuscated Library


Termor

Recommended Posts

Hello,

First of all - I'm certain that this question probably has been asked before, but I tried to google, tried everything I found and didn't get a proper result.

 

What I am doing:

I am using Biomes'O'Plenty as a library for my mod. Since there are no deobfuscated versions of the mod available on curseforge I have to work with the obfuscated one which obviously won't let me run Minecraft in the development environment due to the requirement of an unobfuscated jar. I've read that later versions of Forge automatically deobfuscate the jars (1.8.9+ I think), but this is not the case for me since I work on 1.7.10(Version of the modpack.)

 

Simple compiling with the obfuscated jar works(Although I'm almost certain that compiling with an obfuscated jar could cause errors in some special corner cases):

compile file("eclipse/mods/BiomesOPlenty-1.7.10-2.1.0.2027-universal.jar")

But running then obviously throws a NoSuchMethod exception since the deobfuscated methods do not exist.

Somewhere in the depths of the internet I found a forums post mentioning

compileDeobf file("eclipse/mods/BiomesOPlenty-1.7.10-2.1.0.2027-universal.jar")

But it either seams like this method doesn't exist or won't accept a local file.

I am using local files and not curseforge maven since I couldn't figure out the syntax it required me to use (biomes-o-plenty:BiomesOPlenty-1.7.10:release:universal ??). But that's besides the point and not that big of an issue.

 

So: I'm stuck. I essentially just need a way to deobfuscate the mod to be able to use it in my dev environment.

 

Thanks for your help.

I don't think this matters but I'm using IntelliJ for development.

Link to comment
Share on other sites

  • Guest locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.