Jump to content

Forge for 1.12 not working for me


Recommended Posts

I downloaded the win installer for Minecraft 1.12 ...      forge-1.12-


I ran the installer and had no errors, however when I run the launcher 1.12 Forge does not show up in the menu listing.  The only Forge showing is 1.11.2-forge  1.11.2-


Is the Forge for 1.12 working ?

Link to comment
Share on other sites

Forge for 1.12 is in very early beta. Even if you get it working, the new recipe system is completely nonfunctional and there are probably lots more functions not even slightly existant. Setting up forge for 1.12 is not worth it at the moment, so just wait a couple weeks to start using it.

Link to comment
Share on other sites

When you start minecraft launcher click the menu button. Then select launch options. Select add new. Name it whatever you want then scroll down version types until you find forge 1.12. Select that one and save. Then click news and it will appear under profiles ready to load. Also the version I am using is

Edited by Dusty
Add version type
Link to comment
Share on other sites

  • 9 months later...

1) This thread is a year old. Don't post in it.

2) Using a cracked launcher can get you banned on here. Just buy the game.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.


1.12 -> 1.13 primer by williewillus.


1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.



Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.