Jump to content

I know this isn't a Support forum but.. Gradle.


Gamecool_10

Recommended Posts

Howdy!

 

So, seeing as how a lot of other folks post their issues with gradle here and how the link to the "modder support" forum is dead, I've decided to post this here.

 

Quick backstory: I wanted to try my hand at modding with my somewhat beginner Java knowledge, or at least, have it set up for later. Trouble is I can't even get the workspace setup. Every time I run '.\gradlew setupDecompWorkspace', I get an error.

 

The error: https://pastebin.com/zmGVRt9h

The error with --stacktrace: https://pastebin.com/fMD3rn80

 

The MC version I'm on is 1.12

The JDK version I'm using is "1.8.0_131"

The Forge version I'm using is 14.21.1.2413 (Latest)

 

I've been searching up a solution to this for the past two days but to no avail, I'm sure I'm missing something small. From what I can see, It says that I don't have enough memory to run the dameon. I changed the properties of gradle in my USER_HOME/.gradle/gradle.properties file to use 2 Gigabytes... but it doesn't seem to do it.

 

Any help would be greatly appreciated. I'm really excited to get started on modding Minecraft, but I can't even get past Level 0. If you need any more information, let me know.

 

Thank you in advance!

Link to comment
Share on other sites

Just now, Kokkie said:

What link do you mean with

 

In the stickied post, NO SUPPORT REQUESTS, luacs1998 says: "This is a forum for discussion of ForgeGradle, not for asking for help using it. Please head to Support: http://www.minecraftforge.net/forum/index.php/board,15.0.html"

 

This was also mentioned in the top post of the Forge Support & Bug Reports section. Same link, also dead.

Link to comment
Share on other sites

15 minutes ago, Kokkie said:

At the top of the page there's a link to modder support.

cff73816f4d061eec5f9d12cabf3290a.png

Also, I think http://www.minecraftforge.net/forum/index.php/board,15.0.html  used to be the link to Support & Bug Reports.

Ah, I see now. I suspected that, since my main issue had to do with Gradle, I would post it here.

 

Should I leave this thread up? Or should I delete it and post it in that sub-forum instead?

Link to comment
Share on other sites

15 minutes ago, diesieben07 said:

Make sure you have enough free RAM and you are using a 64-Bit JDK.

How much RAM do I need exactly to run the... I believe it's the JVM? Dameon or JVM, one of those.

 

I downloaded the one that's circled, but now that you mention it, was I supposed to download the other one? I didn't realize until now that the one I downloaded was called "windows-i586"

 

Capture.PNG.125a7f1aad57c40b88b768c4d713f621.PNG

Link to comment
Share on other sites

Ah... sorry for posting again, but I ran into another error and was wondering if any of you folks know what this meant.

 

Alright so, I was able to setupDecompileWorkspace and make a workspace on IntelliJ IDEA using .\gradlw. However, when I tried running the Minecraft Client...

 

Capture.PNG

 

I was presented with this error.

 

https://pastebin.com/F242a1zG

 

It seems that the main problem is presented here:

 

 

[09:58:44] [main/ERROR] [LaunchWrapper]: Unable to launch

     java.util.ConcurrentModificationException
     at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_131]
     at java.util.ArrayList$Itr.remove(ArrayList.java:865) ~[?:1.8.0_131]
     at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
     at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
     at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
     at GradleStart.main(Unknown Source) [start/:?]

 

Searching through the Internet, I found some people had this same issue but... in the 1.6 era of Minecraft. Seems that Java 7 fixed it, but that version of Java isn't available on the Oracle website anymore.

 
Does anyone have some insight on this? Worst case scenario I'll probably just delete everything and start over from scratch.
Edited by Gamecool_10
Formatting
Link to comment
Share on other sites

  • Guest locked this topic
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.