Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft Forge Loader not working (I think)


Recommended Posts

I recently started a server on 1.12.1 (just for me and my friends) and used Minecraft Forge (the correct version) to start this. However, I downloaded FTB Util and FTB Lib from Curse and after I had downloaded them an error message comes up in the run-minecraft when I start the server and someone tries to connect: "[23:29:15] [Netty Server IO #2/INFO] [FML]: Disconnecting Player: This server requires FML/Forge to be installed. Contact your server admin for more details." Due to this, no-one can join my server, which is a major annoyance. I deleted the two mods and it still pops up with this error message along with saying that the mods aren't there which may cause problems. Despite what the error message says, earlier in the launch sequence it says: "[23:28:00] [Server thread/INFO] [FML]: Forge Mod Loader has successfully loaded 7 mods". This confuses me as it proves I have FML installed and it says when a player tries to connect that I don't. Is there any way to fix this, or if I want to keep my world will I have to make a fresh install, creating a new server and copying the world folder over? Sorry if this is very complicated or difficult to understand. Thank you so much for your help :)

Edited by Danielrwood11
Added some extra information, polished grammar.
Link to comment
Share on other sites

10 hours ago, diesieben07 said:

Please post FML logs from both client and server.

Please will you explain to me how to get those?


Edit: I found this file (2017-08-12-7.log) in the logs folder, think it's either just a generic server log or maybe what you're looking for. 

I also found fml-server-latest.log, if that helps too. Still can't find my client logs though.



Edit 2: This time I went into .minecraft\logs, and found a log, it's probably for the game startup so probably useless. Sorry if it is, but it's 2017-08-12-7.log (the second one). So this and 3 are client side.


Edit 3: Apologies for all the edits. Going to add the latest log as well.


Edit 4: Found crash report that could be helpful (on the server side).


Edited by Danielrwood11
Added more information and added logs.
Link to comment
Share on other sites

1 hour ago, diesieben07 said:

The client-side FML log is logs/fml-client-latest.log in your game directory.

The server logs are uneventful, the server crash report shows an issue with Perfectspawn.

I do not have a fml-client-lastest.log in any of my .minecraft folders. The closest thing I had was the latest.log that I put in previously. Sorry.

Link to comment
Share on other sites

Just now, Danielrwood11 said:

Ok, I will install the latest client version of Forge in the game directory, attempt to launch the server again and send you the log files when it is all done. Sorry for the inconvenience.

No, launching the server will not produce client logs.

I need the logs from the clients where the issue occurs.

  • Like 1
Link to comment
Share on other sites

Just now, diesieben07 said:

Like it says you have Mercurius in there for both 1.12 and 1.12.1. I advice you use separate game directories for separate versions.

Installing both versions was unintentional, to be perfectly honest. I only need 1.12.1. Could you tell me where to find the 1.12 version (or where it will probably be) so I can get rid of it?


Link to comment
Share on other sites

  • 7 months later...

hey I'm having the same problem as Daniel and getting the same error of duplicate mercuriusUpdater files but when I go to mercuriusUpdater/1.12.2 I only see one MercuriusUpdater-1.12.2 file iv been fiddling with it for about 2 hours but I'm lost and cant fix it any help would be appreciated very much.

Link to comment
Share on other sites

14 minutes ago, FuLLySicUNiCORNS said:

hey I'm having the same problem as Daniel and getting the same error of duplicate mercuriusUpdater files but when I go to mercuriusUpdater/1.12.2 I only see one MercuriusUpdater-1.12.2 file iv been fiddling with it for about 2 hours but I'm lost and cant fix it any help would be appreciated very much.

Make your own thread and post logs.

Link to comment
Share on other sites

  • 1 year later...

hey, i have like the same problem, but at the same time completly different, my friend got a server with FTB Trident, and it worked one day. when he wanted to start it today, we first got the message, that ther server isn'T on, then he restarted, jet we can see it online, but if we wan't to join we get the message:

This server has mods that require FML/Forge to be installed on the client. contact your server admin for more details

Link to comment
Share on other sites

Please don't necro old threads, especially when you are hijacking at the same time.

Please make your own thread and include logs.

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.