Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[solved] broken javascript on forum


Recommended Posts

Most (maybe all) javascript on this forum is dead for my Firefox 19. I can't see a toolbar when writing this post, I can't see fancy effects on buttons on top of this page, I had to hack css of this site just to see text in spoiler tags..

 

I think it might be related to this crash of JS:

Timestamp: 23/02/2013 19:39:05
Error: TypeError: b is null
Source File: http://ajax.cloudflare.com/cdn-cgi/nexp/abv=4114775854/cloudflare.min.js
Line: 22

 

Any idea what might be causing this (I suppose it's not a bug of this site, but some problem with my browser)?

mnn.getNativeLang() != English

If I helped you please click on the "thank you" button.

Link to post
Share on other sites

There should be no way that 'b' should be null if the javascript has access to the page layout at all.  Is it only a FF19 problem?  Might be a bug on their side...  I use chrome (and forced to use IE at work) myself, and my firefox at home is old, 14 I think, but it did work fine last I tried.

Link to post
Share on other sites

Opera (11.62), Chrome(23), IE9 - all of them works fine. Only in FF it's broken. I have tried trurning off all addons that can change pages, no success.

 

PS: I tried it in clean FF19 (no addons, new profile) and it still wasn't working. It would seem this site does not support Firefox O_0.

mnn.getNativeLang() != English

If I helped you please click on the "thank you" button.

Link to post
Share on other sites
  • 2 weeks later...

problem persists.

 

I looked closely at the clean FF and I discovered that the cloudflare's javascript is crashing on a different error:

Timestamp: 05/03/2013 10:28:20
Error: SecurityError: The operation is insecure.
Source File: http://ajax.cloudflare.com/cdn-cgi/nexp/abv=4114775854/cloudflare.min.js
Line: 20

 

No one else using FF is having these problems?

mnn.getNativeLang() != English

If I helped you please click on the "thank you" button.

Link to post
Share on other sites
  • 1 month later...

Problem solved, I allowed DOM storage ("supercookies") for forum and now it works as intended.

mnn.getNativeLang() != English

If I helped you please click on the "thank you" button.

Link to post
Share on other sites

Problem solved, I allowed DOM storage ("supercookies") for forum and now it works as intended.

mnn.getNativeLang() != English

If I helped you please click on the "thank you" button.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.