Jump to content

[1.10.2] Entity Attributes


vin0m

Recommended Posts

Is there any reason why in the code below the change to the health attribute will work but the movement speed does not?

 

@SubscribeEvent
	public void onLogin(PlayerLoggedInEvent event){
		Entity player = event.player;
			((EntityLivingBase) player).getEntityAttribute(SharedMonsterAttributes.MOVEMENT_SPEED).setBaseValue(100.0D);
			((EntityLivingBase) player).getEntityAttribute(SharedMonsterAttributes.MAX_HEALTH).setBaseValue(50.0D);
	}
	


 

Link to comment
Share on other sites

In case anyone needs it, here is the code I used to change the movement speed:

AttributeModifier boostSpeed = new AttributeModifier(playerUUID, "vmodspeed", 1.0D, 2).setSaved(true);
		
((EntityLivingBase) player).getEntityAttribute(SharedMonsterAttributes.MOVEMENT_SPEED).removeAllModifiers();
((EntityLivingBase) player).getEntityAttribute(SharedMonsterAttributes.MOVEMENT_SPEED).applyModifier(boostSpeed);

 

Edited by vin0m
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.