Jump to content

Fatally missing registry entries


mickkay

Recommended Posts

Hello Forge Team!

 

I have recently upgraded my self-made mod from MC 1.11.2 to 1.12.2. 

Since then all forge clients that try to connect to the modded server get this error message "Fatally missing registry entries".

 

Here is the relevant part from the client's fml-junk-earlystartup.log:

[08:06:26] [Netty Client IO #13/TRACE] [FML]:   Registry: 103 minecraft:llama net.minecraftforge.fml.common.registry.EntityEntry@280d5a82
[08:06:26] [Netty Client IO #13/TRACE] [FML]:   Registry: 104 minecraft:llama_spit net.minecraftforge.fml.common.registry.EntityEntry@1a34a51e
[08:06:26] [Netty Client IO #13/TRACE] [FML]:   Registry: 105 minecraft:parrot net.minecraftforge.fml.common.registry.EntityEntry@3bf5911d
[08:06:26] [Netty Client IO #13/TRACE] [FML]:   Registry: 120 minecraft:villager net.minecraftforge.fml.common.registry.EntityEntry@17136390
[08:06:26] [Netty Client IO #13/TRACE] [FML]:   Registry: 200 minecraft:ender_crystal net.minecraftforge.fml.common.registry.EntityEntry@273293c8
[08:06:26] [Netty Client IO #13/INFO] [FML]: Registry EntityEntry: Found a missing id from the world wol:spell
[08:06:27] [Netty Client IO #13/DEBUG] [FML]: There are 1 mappings missing - attempting a mod remap
[08:06:27] [Netty Client IO #13/ERROR] [FML]: Unidentified mapping from registry minecraft:entities
[08:06:27] [Netty Client IO #13/ERROR] [FML]:     wol:spell: 0
[08:06:27] [Netty Client IO #13/DEBUG] [FML]: Processing missing event for minecraft:entities:
[08:06:27] [Netty Client IO #13/DEBUG] [FML]:   Next: ERROR
[08:06:27] [Netty Client IO #13/ERROR] [FML]: Network Disconnect: Fatally missing registry entries
[08:06:27] [Netty Client IO #13/FATAL] [FML]: Failed to connect to server: there are 1 missing registry items
[08:06:27] [Netty Client IO #13/DEBUG] [FML]: Missing minecraft:entities Entries: [wol:spell]
[08:06:27] [Netty Client IO #13/DEBUG] [FML]: FMLHandshakeClientState: $HandshakeAck:{2}->FMLHandshakeClientState$8:ERROR

 

However, plain vanilla clients have no problems to connect.

 

I know this has to do with entity IDs missing on the client side.

The entity IDs are missing because the clients haven't installed my mod at all.

However, this "should" be fine, since my mod is supposed to be a "server-side only" mod.

 

My question is now: can I somehow get rid of this error message, so that forge clients can log into the server, like the vanilla clients already can?

 

Is there, for example, a way to skip this ID test on the client, or some setting, that prevents the sending of the mod-specific entity IDs from the server to client?

For example, I found out that I just could skip the entity registration (done with the EntityEntryBuilder), which makes the my entity class unknown to the server and client, but I am not sure if that is the correct approach to this. It works, but I guess this has bad side effects, hasn't it?

 

My setup is the following:

1) I have Forge 1.12.2-14.23.2.2651 on the server

2) I have Wizards of Lua Mod (that's my mod, version is some alpha for MC 1.12.2, not yet released because of this issue) on the server

3) The client has Forge 1.12.2-14.23.1.2555 installed

4) No other mod are installed on the client.

 

Please note that the respective entity I have on the server does not need to by synced to the client. It is really server-only.

And well, it worked in MC 1.11.2, just not in MC 1.12.2.

 

I really would like to support not only vanilla clients to connect to my server mod but also forge clients.

If you know how to do it, I appreciate any hit.

Thank you very much for any feedback.

 

Cheers

MickKay

Link to comment
Share on other sites

Alright, I'll try to elaborate.

 

Out server-only entities are invisible spells. 

A spell can be casted by the player by issuing the mod-specific "/lua" command, followed by a short Lua program.

This works from the chat line and from within command blocks.

 

When a spell is casted, a SpellEntity is created exactly at the position the player is looking at (or at the command block's location). Then the spell is performing whatever task has been assigned to it, for example, running some while-loop and replacing some blocks. This is done inside the entity's update method. Since the spell entity is completely invisible, nothing needs to be transferred to the client. All actions are executed on the server only.

However, if the spell changes some blocks or issues a Minecraft command, the effects of this action is synchronized to the player. For example, when the player wants to see the spell, he can add some statement to the spell's program that issues a "/particle" command. In this case the command is executed on the server, particles are created at the spell's position, and transferred from the server to the client, which is no problem, since this is vanilla Minecraft behavior. Same is true for block updates.

Here is a video that shows a Lua spell performing Conways Game of Life: 

 

 

 

I am using this approach since the first prototype that has been created in early 2017 with Minecraft 1.10, and later 1.11, and it works like a charm.

If you are curious, you can play with the latest alpha version which is available at Curse: https://minecraft.curseforge.com/projects/wizards-of-lua/files, and some documentation can be found at http://www.wizards-of-lua.net

 

I like the idea that a spell is actually an entity that lives inside the world like all other entities. It belongs to a specific dimension, it has a location, it can move around like Logo turtle, it can modify the block at its location, it can be a command sender, and the like.

Additionally it can listen for any Forge event and react to it. For example, it can wait for a specific action of the player and then cast another spell that does something special in reaction to this event.

Since spells are real entities they run completely independent and "parallel".

Long programs do not "eat up" big amounts of time during the game tick, since they use an internal scheduler that suspends the spell's program after a specific amount of "lua ticks", and resumes it not before the next game tick.

When a spell has finished its task, it terminates, which means it actually calls "setDead(true)" on itself.

 

We were planning to release the first "non-alpha" version for Minecraft 1.12.2 in the next weeks, since upgrading to 1.12 is the last ticket we have in our backlog. But it turned out that our beta testers could only log into the server if they use a vanilla client. Anybody who uses a Forge modded client, for example, in order to use some client-side Minimap mod, could not log in.

As a work around they installed the Wizards of Lua mod also on their client. That works, but is, of course, completely senseless, because nothing is done client-side.

 

Again, if you have any idea how this could be solved, I really appreciate it!!!

Cheers

MickKay

 

 

Link to comment
Share on other sites

Oh, I see.

This would mean to rewrite the mod's core.

 

I guess we stay at MC 1.11.2 for now. Too bad.

 

Just a desperate idea - provided that we could add this in far less time to Forge than to rewrite our SpellEntity into something like a tick handler that can simulate an entity, would the Forge team be interested into code contributions that add support for the "server-only entities" feature for MC 1.12.2?

 

Cheers

MickKay

Link to comment
Share on other sites

Anyway, I can give you an idea about why this works in MC 1.11.2 but not in MC 1.12.2.

I debugged the Forge client code for both versions and found the difference.

 

In Forge for MC 1.11.2 only missing blocks and items were interpreted as fatal error, while in Forge for MC 1.12.2 all registries are checked for missing entries, which includes entities.

 

Here is the relevant code:

 

In Forge for 1.11.2 the PresistentRegistryManager has the following statements at line 319:

// If we have missed data, fire the missing mapping event
List<String> missedMappings = Loader.instance().fireMissingMappingEvent(missing.get(BLOCKS), missing.get(ITEMS), isLocalWorld, remaps.get(BLOCKS), remaps.get(ITEMS));
// If there's still missed mappings, we return, because that's an error
if (!missedMappings.isEmpty())
{
  return missedMappings;
}

Since only "ITEMS" and "BLOCKS" are searched, the "missedMappings" does not contain my spell entity and instead stays empty.

So no error is issued.

 

The respective code segment in Forge for 1.12.2 is in GameData, beginning at line 570:

missing.entrySet().stream().filter(e -> e.getValue().size() > 0).forEach(m ->
{
	ResourceLocation name = m.getKey();
	ForgeRegistry<?> reg = STAGING.getRegistry(name);
	RegistryEvent.MissingMappings<?> event = reg.getMissingEvent(name, m.getValue());
	MinecraftForge.EVENT_BUS.post(event);

	List<MissingMappings.Mapping<?>> lst = event.getAllMappings().stream().filter(e -> e.getAction() == MissingMappings.Action.DEFAULT).sorted((a, b) -> a.toString().compareTo(b.toString())).collect(Collectors.toList());
	if (!lst.isEmpty())
	{
		FMLLog.log.error("Unidentified mapping from registry {}", name);
		lst.forEach(map -> FMLLog.log.error("    {}: {}", map.key, map.id));
	}
	event.getAllMappings().stream().filter(e -> e.getAction() == MissingMappings.Action.FAIL).forEach(fail -> failed.put(name, fail.key));

	final Class<? extends IForgeRegistryEntry> clazz = RegistryManager.ACTIVE.getSuperType(name);
	processMissing(clazz, name, STAGING, event, m.getValue(), remaps.get(name), defaulted.get(name), failed.get(name), !isLocalWorld);
});

if (!defaulted.isEmpty() && !isLocalWorld)
	return defaulted;

 

Here is every ForgeRegistry searched for missing entries, including the registry for entities. This is why the "defaulted" map is not empty and returned to the caller, which in turn issues the error message "Fatally missing registry entries".

 

Edited by mickkay
Link to comment
Share on other sites

PS:

It looks like MC 1.12.2 has no problem with missing entity ids that are "server-only".

 

I already tested this in code. I just disabled the relevant part in FMLHandshakeClientState (line 156 ff) that issued the error:

Multimap<ResourceLocation, ResourceLocation> locallyMissing = GameData.injectSnapshot(snap, false, false);
// if (!locallyMissing.isEmpty())
// {
//  cons.accept(ERROR);
//  NetworkDispatcher dispatcher = ctx.channel().attr(NetworkDispatcher.FML_DISPATCHER).get();
//  dispatcher.rejectHandshake("Fatally missing registry entries");
//  FMLLog.log.fatal("Failed to connect to server: there are {} missing registry items", locallyMissing.size());
//  locallyMissing.asMap().forEach((key, value) ->  FMLLog.log.debug("Missing {} Entries: {}", key, value));
//  return;
//}
cons.accept(PENDINGCOMPLETE);
ctx.writeAndFlush(new FMLHandshakeMessage.HandshakeAck(ordinal())).addListener(ChannelFutureListener.FIRE_EXCEPTION_ON_FAILURE);

 

Then I started the client. I could connect to the modded server without problems and also play with it long enough to see that MC had no problems with any missing entity ids.

Of course the code above is not the patch that is needed. 

 

But it shows that it would be very easy to support server-only entities in Forge.

The only thing we would have to do is to prevent the transmission of the server-only entity ids to the client during the handshake.

Then the handshake would succeed without error and the client could connect to the server.

 

To implement this, I would suggest to add an (optional) boolean flag, or an enum property if you prefer, to the EntityEntryBuilder, that marks the entity as server-only. This flag should be used by the server to filter the entity ids that are sent to the client during the handshake.

 

What you you think?

Are there any chances that the Forge team would like to support "server-only entities"?

 

Cheers

MickKay

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Sorry, but I would like to ask if anyone else is experiencing the problem: java.lang.ClassCastException: class net.minecraft.client.player.LocalPlayer cannot be cast to class net.minecraft.server.level.ServerPlayer (net.minecraft.client .player.LocalPlayer and net.minecraft.server.level.ServerPlayer are in module [email protected] of loader 'TRANSFORMER' @19a64eae) This problem appeared yesterday, while I was testing parts of my mod, which I had previously tested. I thought I might have messed up somewhere, so today I went back to a previous version, already tested and functional, and it turns out that I ran into the same problem. Someone knows what is due? I can't share the entire code, but I can give you the parts that cause the error, I hope you can help me. Thanks in advance.   DataUtil Class public static void setBooleanOnServerAndSync(Player p, String key, boolean value, boolean temporary) { p.getCapability(PlayerDataProvider.PLAYER_DATA, null).ifPresent(playerData -> { playerData.setBoolean(key, value, temporary); Messages.sendToPlayer(SyncPlayerDataPacket.toClient(key).setBoolean(value), (ServerPlayer) p); //It fails here if (value) { ResearchUtil.markResearchAsUpdated(p, key); } }); } Gui that calls the previous method public void tick() { this.timePassed++; if (this.timePassed > 1000) { this.minecraft.setScreen(null); assert minecraft.level != null; assert minecraft.player != null; DataUtil.setBooleanOnServerAndSync(Objects.requireNonNull(minecraft.level.getPlayerByUUID(minecraft.player.getUUID())),"eldritchDream", true,false); } else if (this.timePassed == 20) { Minecraft.getInstance().player.playSound(Registration.DREAM_ALIENIS.get(), 1, 1); } super.tick(); } Error Log (Website paste.ee)
    • This is the code for my enchantment tags provider for data generation: public final class ModEnchantmentTagsProvider extends EnchantmentTagsProvider { public ModEnchantmentTagsProvider(PackOutput packOutput, CompletableFuture<Provider> lookupProvider) { super(packOutput, lookupProvider); } @Override protected void addTags(Provider provider) { tag(EnchantmentTags.ARMOR_EXCLUSIVE) .add(ArmorEnchantments.FREEZING_PROTECTION) .add(ArmorEnchantments.LIGHTNING_PROTECTION) .add(ArmorEnchantments.MAGIC_PROTECTION) .add(ArmorEnchantments.SONIC_PROTECTION); tag(ModEnchantmentTags.XP_GAIN_EXCLUSIVE) .add(Enchantments.MENDING) .add(ArmorEnchantments.EXPLORATION); } @Override public String getName() { return "Unique Magic Enchantment Tags"; } }   So what am I doing here is: 1) Adding my custom protection enchantments to be ARMOR_EXCLUSIVE so they don't clash with existing protection enchantments 2) Adding tag that makes my custom EXPLORATION enchantment to be exclusive with MENDING enchantment This is then registered in ModDataGenerators: dataGen.addProvider(event.includeServer(), new ModEnchantmentTagsProvider(packOutput, lookupProvider)); When datagen is run, I end up with this error: Caused by: java.util.concurrent.CompletionException: java.lang.IllegalArgumentException: Couldn't define tag minecraft:exclusive_set/armor as it is missing following references: uniquemagic:freezing_protection,uniquemagic:lightning_protection,uniquemagic:magic_protection,uniquemagic:sonic_protection Enchantments have been migrated to 1.21 and they work in game as they did in 1.20.6. I also get enchantment JSON files in src/generated/resources so that is working well too. However, I cannot make these tags to work no matter what I try. Is there something that I am missing?  
    • Help me, I deleted the mods that were complained about in loge, but nothing changes Log: java version "19.0.2" 2023-01-17 Java(TM) SE Runtime Environment (build 19.0.2+7-44) Java HotSpot(TM) 64-Bit Server VM (build 19.0.2+7-44, mixed mode, sharing) Hosting-Minecraft: Проверка файлов сервера на наличие Forge 1.17+  Hosting-Minecraft: Forge не найден, выполняем стандартный запуск jar файла... Hosting-Minecraft: java -Xms128M -XX:MaxRAMPercentage=95.0 -Dsip=65.108.21.152 -Dspt=25630 -XX:ConcGCThreads=2 -XX:ParallelGCThreads=2 -XX:+UseSerialGC -DPaper.IgnoreJavaVersion=true -Dfml.readTimeout=1024 -Dfml.queryResult=confirm -Dlog4j2.formatMsgNoLookups=true -Dterminal.jline=false -Dterminal.ansi=true -DIReallyKnowWhatIAmDoingISwear=true -Duser.timezone=Europe/Moscow -jar -Dfile.encoding=UTF-8 server.jar nogui Starting net.fabricmc.loader.impl.game.minecraft.BundlerClassPathCapture [13:43:46] [main/INFO]: Loading Minecraft 1.19.2 with Fabric Loader 0.15.11 [13:43:46] [ForkJoinPool-1-worker-1/WARN]: The mod "moreculling" contains invalid entries in its mod json: - Unsupported root entry "embedded" at line 35 column 13 [13:43:46] [ForkJoinPool-1-worker-2/WARN]: Mod structory uses the version 1.3.1a which isn't compatible with Loader's extended semantic version format (Could not parse version number component '1a'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version [13:43:46] [ForkJoinPool-1-worker-2/WARN]: Mod letmedespawn uses the version fabric-1.0.2 which isn't compatible with Loader's extended semantic version format (Could not parse version number component 'fabric'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version [13:43:46] [ForkJoinPool-1-worker-1/WARN]: Mod brewinandchewin uses the version fabric-2.0.0+1.19.2 which isn't compatible with Loader's extended semantic version format (Could not parse version number component 'fabric'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version [13:43:46] [ForkJoinPool-1-worker-1/WARN]: Mod booking_it uses the version unversioned which isn't compatible with Loader's extended semantic version format (Could not parse version number component 'unversioned'!), SemVer is recommended for reliably evaluating dependencies and prioritizing newer version [13:43:46] [main/WARN]: Warnings were found!  - Mod 'Trinkets Curios Theme' (trinkets-curios-theme) 0.2.2+1.19 recommends any version of scout, which is missing!          - You should install any version of scout for the optimal experience. [13:43:46] [main/INFO]: Loading 294 mods:         - additionz 1.1.10         - advanced_runtime_resource_pack 0.6.4         - advdebug 2.3.0         - adventurez 1.4.18         - amecs 1.3.8+mc.1.19-rc2            \-- amecsapi 1.3.6+mc22w17a         - another_furniture 2.1.2-1.19.2         - appleskin 2.4.1+mc1.19         - attributefix 17.2.6         - autotag-convention 2.0.0+1.19            \-- autotag 2.0.0+1.19         - backslot 1.2.11            \-- amecsapi 1.3.6+mc22w17a         - backslotaddon 1.0.10         - balm-fabric 4.5.7         - bclib 2.1.7         - beautify 1.1.1+fabric-1.19.2            |-- cardinal-components-base 5.0.2            |-- cardinal-components-entity 5.0.2            \-- cardinal-components-world 5.0.2         - betteradvancements 0.2.2.147         - bettercombat 1.7.1+1.19         - betterdeserttemples 1.19.2-Fabric-2.2.2            \-- org_reflections_reflections 0.10.2         - betterdungeons 1.19.2-Fabric-3.2.1         - betterend 2.1.6         - betterfortresses 1.19.2-Fabric-1.0.5         - betterladdersmod 0.0.1-1.19.2         - bettermineshafts 1.19.2-Fabric-3.2.0         - betternether 7.1.4         - betteroceanmonuments 1.19.2-Fabric-2.1.0         - betterstats 2.8.1+1.19.2            |-- architectury 6.5.77            \-- tcdcommons 2.8+1.19.2         - betterthanmending 1.3.0         - blossom 1.0.7         - bookshelf 16.3.20         - brewinandchewin fabric-2.0.0+1.19.2            |-- booking_it unversioned            |    \-- mm 2.3            \-- mm 2.3         - bushierflowers 0.0.1-1.19.2         - cardinal-components 5.0.2            |-- cardinal-components-base 5.0.2            |-- cardinal-components-block 5.0.2            |-- cardinal-components-chunk 5.0.2            |-- cardinal-components-entity 5.0.2            |-- cardinal-components-item 5.0.2            |-- cardinal-components-level 5.0.2            |-- cardinal-components-scoreboard 5.0.2            \-- cardinal-components-world 5.0.2         - cavedust 1.2.0            \-- kirin 1.11.1-beta.1         - charmofundying 6.2.0+1.19.2         - chipped 2.1.5         - ciif 1.0.0+1.19         - cloth-config 8.2.88            \-- cloth-basic-math 0.6.1         - collective 6.57         - combatroll 1.1.5+1.19         - connectiblechains 2.1.4+1.19.2         - corgilib 1.0.0.34            |-- com_electronwill_night-config_core 3.6.6            \-- com_electronwill_night-config_toml 3.6.6         - couplings 1.9.1+1.19         - crawl 0.11.1            \-- mm 2.3         - creativecore 2.9.3         - creaturesfromthesnow 4.1.0+1.19.2         - creeperoverhaul 2.0.9         - customportals 3.2.0            |-- cardinal-components-base 5.0.2            |-- cardinal-components-world 5.0.2            |-- completeconfig-base 2.1.0            \-- completeconfig-gui-cloth 2.1.0         - customspawns 0.7+1.19         - dawn 3.5.0         - debugify 2.8.0         - defaultoptions 15.0.1         - dehydration 1.3.4         - disenchanter 0.1.7+1.19         - do_a_barrel_roll 2.6.2+1.19.2            |-- cardinal-components-base 5.0.2            |-- cardinal-components-entity 5.0.2            \-- cicada 0.1.2                 \-- langfiles-plus 1.0.0         - dummmmmmy 1.19.2-1.7.2         - dungeonz 1.0.1         - earlystage 1.0.10         - easymagic 4.3.3         - ecologics 2.1.11         - elytraslot 6.1.1+1.19.2         - emi 1.0.2+1.19.2+fabric         - emi_loot 0.6.2+1.19         - emiffect 0.1.5+mc1.19.2         - enchanted-vertical-slabs 1.8         - enderscape 0.3.5-1.19.1         - endrem 5.2.0         - entitycollisionfpsfix 2.0.0.0         - environmentz 2.0.5            \-- satin 1.9.0         - eventmod 1.0.5         - expandeddelight 0.2.5         - experiencebottler 1.19+build.2         - fabric-api 0.76.0+1.19.2            |-- fabric-api-base 0.4.15+8f4e8eb390            |-- fabric-api-lookup-api-v1 1.6.14+93d8cb8290            |-- fabric-biome-api-v1 9.1.1+16f1e31390            |-- fabric-block-api-v1 1.0.2+e415d50e90            |-- fabric-blockrenderlayer-v1 1.1.25+cafc6e8e90            |-- fabric-client-tags-api-v1 1.0.5+b35fea8390            |-- fabric-command-api-v1 1.2.16+f71b366f90            |-- fabric-command-api-v2 2.2.1+413cbbc790            |-- fabric-commands-v0 0.2.33+df3654b390            |-- fabric-containers-v0 0.1.41+df3654b390            |-- fabric-content-registries-v0 3.5.2+7c6cd14d90            |-- fabric-convention-tags-v1 1.3.0+4bc6e26290            |-- fabric-crash-report-info-v1 0.2.8+aeb40ebe90            |-- fabric-data-generation-api-v1 5.3.8+413cbbc790            |-- fabric-dimensions-v1 2.1.35+0d0f210290            |-- fabric-entity-events-v1 1.5.4+9244241690            |-- fabric-events-interaction-v0 0.4.34+562bff6e90            |-- fabric-events-lifecycle-v0 0.2.36+df3654b390            |-- fabric-game-rule-api-v1 1.0.24+b6b6abb490            |-- fabric-item-api-v1 1.6.6+b7d1888890            |-- fabric-item-groups-v0 0.3.39+9244241690            |-- fabric-key-binding-api-v1 1.0.25+5c4fce2890            |-- fabric-keybindings-v0 0.2.23+df3654b390            |-- fabric-lifecycle-events-v1 2.2.4+1b46dc7890            |-- fabric-loot-api-v2 1.1.13+83a8659290            |-- fabric-loot-tables-v1 1.1.16+9e7660c690            |-- fabric-message-api-v1 5.0.7+93d8cb8290            |-- fabric-mining-level-api-v1 2.1.24+33fbc73890            |-- fabric-models-v0 0.3.21+c6af733c90            |-- fabric-networking-api-v1 1.2.11+10eb22f490            |-- fabric-networking-v0 0.3.28+df3654b390            |-- fabric-object-builder-api-v1 4.2.2+d8ef690890            |-- fabric-particles-v1 1.0.14+4d0d570390            |-- fabric-recipe-api-v1 1.0.1+413cbbc790            |-- fabric-registry-sync-v0 0.9.32+9244241690            |-- fabric-renderer-api-v1 1.2.1+1adbf27790            |-- fabric-renderer-indigo 0.8.0+1adbf27790            |-- fabric-renderer-registries-v1 3.2.24+df3654b390            |-- fabric-rendering-data-attachment-v1 0.3.19+6e0787e690            |-- fabric-rendering-fluids-v1 3.0.11+4d0d570390            |-- fabric-rendering-v0 1.1.27+df3654b390            |-- fabric-rendering-v1 1.12.1+d8ef690890            |-- fabric-resource-conditions-api-v1 2.1.2+aae9039d90            |-- fabric-resource-loader-v0 0.8.4+edbdcddb90            |-- fabric-screen-api-v1 1.0.32+4d0d570390            |-- fabric-screen-handler-api-v1 1.3.7+1cc24b1b90            |-- fabric-sound-api-v1 1.0.2+c4f28df590            |-- fabric-textures-v0 1.0.24+aeb40ebe90            |-- fabric-transfer-api-v1 2.1.6+413cbbc790            \-- fabric-transitive-access-wideners-v1 1.3.3+08b73de490         - fabric-language-kotlin 1.9.5+kotlin.1.8.22            |-- org_jetbrains_kotlin_kotlin-reflect 1.8.22            |-- org_jetbrains_kotlin_kotlin-stdlib 1.8.22            |-- org_jetbrains_kotlin_kotlin-stdlib-jdk7 1.8.22            |-- org_jetbrains_kotlin_kotlin-stdlib-jdk8 1.8.22            |-- org_jetbrains_kotlinx_atomicfu-jvm 0.20.2            |-- org_jetbrains_kotlinx_kotlinx-coroutines-core-jvm 1.7.1            |-- org_jetbrains_kotlinx_kotlinx-coroutines-jdk8 1.7.1            |-- org_jetbrains_kotlinx_kotlinx-datetime-jvm 0.4.0            |-- org_jetbrains_kotlinx_kotlinx-serialization-cbor-jvm 1.5.1            |-- org_jetbrains_kotlinx_kotlinx-serialization-core-jvm 1.5.1            \-- org_jetbrains_kotlinx_kotlinx-serialization-json-jvm 1.5.1         - fabricloader 0.15.11            \-- mixinextras 0.3.5         - fabricshieldlib 1.7-1.19.2            \-- mm 2.3         - fancymenu 2.14.7         - farmersdelight 1.19.2-1.3.9         - farmersrespite 2.2.4            \-- porting_lib 2.1.656+1.19.2                 |-- forge_tags 3.0                 |-- porting_lib_base 2.1.656+1.19.2                 |    \-- serialization_hooks 0.3.26                 |-- porting_lib_entity 2.1.656+1.19.2                 |-- porting_lib_lazy_registration 2.1.656+1.19.2                 |-- porting_lib_model_generators 2.1.656+1.19.2                 |-- porting_lib_models 2.1.656+1.19.2                 |-- porting_lib_networking 2.1.656+1.19.2                 |-- porting_lib_obj_loader 2.1.656+1.19.2                 |    \-- porting_lib_model_loader 2.1.656+1.19.2                 \-- porting_lib_transfer 2.1.656+1.19.2                      \-- porting_lib_extensions 2.1.656+1.19.2                           |-- porting_lib_accessors 2.1.656+1.19.2                           |-- porting_lib_attributes 2.1.656+1.19.2                           |    \-- porting_lib_constants 2.1.656+1.19.2                           \-- porting_lib_common 2.1.656+1.19.2         - ferritecore 5.0.3         - forgeconfigapiport 4.2.11         - frame 0.26.1+1.19-fabric            |-- frame-api-base 0.2.1+906ebc04a9            |-- frame-blocks-v0 0.1.3+233e7428a9            |-- frame-config-v0 0.3.1+0fa45150a9            |-- frame-content-registries-v0 0.4.0+2876b511a9            |-- frame-enchantments-v0 0.1.0+4093105da9            |    \-- mm 2.3            |-- frame-game-rules-v0 0.2.4+e7ce56a6a9            |-- frame-items-v0 0.1.3+906ebc04a9            |-- frame-loot-tables-v0 0.1.4+4f7341eca9            |-- frame-registries-v0 0.1.1+0e0ec74ea9            |-- frame-rendering-v0 0.1.5+906ebc04a9            |-- frame-tabbed-item-groups-v0 0.2.4+0aca9b56a9            |-- frame-toymaker-v0 0.6.1+b13741c3a9            \-- frame-woods-v0 0.2.1+6a33fbada9         - geckolib3 3.1.40            \-- com_eliotlash_mclib_mclib 20         - geodes 1.7+1.19         - geophilic 1.19-2.0.0b         - go-fish 1.6.0-1.19.1         - guarding 1.19.2+2.2.0         - handcrafted 2.0.6         - herdspanic 1.0.6         - hopobetterunderwaterruins 1.1.1         - horseexpert 4.0.0         - ice_boat_nerf 1.0.14         - iceberg 1.0.46         - immersive_armors 1.5.5+1.19.2         - inmis 2.7.1-1.19            \-- omega-config 1.2.3-1.18.1         - inmisaddon 1.0.4         - interactic 0.1.11+1.19         - java 19         - jobsaddon 1.1.1         - jumpoverfences 1.1.0         - konkrete 1.6.1         - lazydfu 0.1.3         - letmedespawn fabric-1.0.2         - levelz 1.4.9         - libz 1.0.0         - lithium 0.11.1         - logbegone 1.0.6         - lootr 0.4.26.65         - mcwfences 1.0.7         - mcwwindows 2.1.2         - medievalweapons 1.4.5            \-- reach-entity-attributes 2.3.0         - midnightlib 1.0.0         - minecraft 1.19.2         - modernfix 3.7.1            |-- fabric-models-v0 0.3.21+c6af733c90            \-- fabric-screen-api-v1 1.0.32+4d0d570390         - moisturization 1.2.1         - moonlight 1.19.2-2.2.38         - moremobvariants 1.0.1         - musketmod 1.4.6         - nameplate 1.1.3         - naturalist 3.0.2         - nbtcrafting 2.2.3+mc1.19         - netherportalfix 10.0.1         - nethersdelight 1.0.1            \-- disable_custom_worlds_advice 3.0         - nochatreports 1.19.2-v1.13.12            |-- fabric-rendering-v1 1.11.0+73145abb90            \-- fabric-screen-api-v1 1.0.27+93d8cb8290         - numismatic-overhaul 0.2.8+1.19            |-- cardinal-components-base 5.0.2            |-- cardinal-components-entity 5.0.2            \-- stacc 1.3.3         - numismaticclaim 1.0.8         - onsoulfire 1.19-2         - openpartiesandclaims 0.17.3         - overweight_farming 1.19.2-2.0.2-fabric            |-- playerabilitylib 1.6.0            |-- reach-entity-attributes 2.3.0            \-- terraform-wood-api-v1 4.2.0         - owo 0.9.3+1.19            \-- blue_endless_jankson 1.2.1         - partyaddon 1.0.3         - patchouli 1.19.2-77-FABRIC            \-- fiber 0.23.0-2         - patchoulibutton 1.0.2         - paxi 1.19.2-Fabric-3.0.1         - player-animator 1.0.2         - polymorph 0.46.1+1.19.2         - puzzleslib 4.4.0            |-- cardinal-components-base 5.0.2            |-- cardinal-components-block 5.0.2            |-- cardinal-components-chunk 5.0.2            |-- cardinal-components-entity 5.0.2            \-- cardinal-components-world 5.0.2         - realisticfirespread 1.19-2         - reciperemover 1.0.5         - resourcefulconfig 1.0.20         - resourcefullib 1.1.24         - revive 1.0.5         - rotten 1.4.7         - rpgdifficulty 1.3.12         - seasons 2.2.1+1.19         - seasonsextras 1.2-BETA+1.19         - sleepwarp 2.0.0+1.19.2         - sod 22.10.13         - sootychimneys 1.0         - sound_physics_remastered 1.19.2-1.0.18         - spark 1.10.37            \-- fabric-permissions-api-v0 0.1-SNAPSHOT         - spectrelib 0.12.7+1.19.2         - spiceoffabric 1.6.0-beta.4+1.19.2            |-- capsaicin 1.3.1+mc1.19.3            |-- coat 1.0.0-beta.18+mc22w17a            |-- tweed4_annotated 1.3.1+mc22w17a            |-- tweed4_base 1.7.1+mc22w17a            |-- tweed4_data 1.2.1+mc22w17a            |-- tweed4_data_hjson 1.1.1+mc22w17a            |-- tweed4_tailor_coat 1.1.3+mc22w17a            \-- tweed4_tailor_screen 1.1.1+mc22w17a         - spoiledz 1.0.7         - starlight 1.1.1+fabric.ae22326         - starterkit 5.2         - stendhal 1.3.4-1.19            \-- libgui 6.0.0-beta.5+1.19-pre1                 |-- jankson 4.1.1+j1.2.1                 \-- libninepatch 1.1.0         - structory 1.3.1a         - suggestion_tweaker 1.19.1-1.4.1         - t_and_t 1.10         - takesapillage 1.0.4         - tawct 1.4.3+1.19.2         - tiered 1.2.7            \-- reach-entity-attributes 2.3.0         - tlc 1.0.0         - toms_storage 1.5.7         - treechop 0.17.6         - trinkets 3.4.2         - trinkets-curios-theme 0.2.2+1.19         - universal_ores 1.4.2         - villagerfix 1.0.3         - vinery 1.2.3            \-- terraform-wood-api-v1 4.2.0         - voicechat 1.19.2-2.4.9            \-- fabric-key-binding-api-v1 1.0.18+9ff28f4095         - voidz 1.0.9         - waterdripsound 1.19-0.3.0         - wwoo 3.1.9.1         - xaeroworldmap 1.30.3         - yet-another-config-lib 2.2.0-for-1.19.2         - yungsapi 1.19.2-Fabric-3.8.9            \-- org_javassist_javassist 3.28.0-GA [13:43:46] [main/INFO]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=file:/home/container/libraries/net/fabricmc/sponge-mixin/0.13.3+mixin.0.8.5/sponge-mixin-0.13.3+mixin.0.8.5.jar Service=Knot/Fabric Env=SERVER [13:43:46] [main/INFO]: Compatibility level set to JAVA_17 [13:43:47] [main/WARN]: Reference map 'dummmmmmy-fabric-refmap.json' for dummmmmmy.mixins.json could not be read. If this is a development environment you can ignore this message [13:43:47] [main/INFO]: Loaded configuration file for Lithium: 114 options available, 1 override(s) found [13:43:47] [main/INFO]: Loaded configuration file for ModernFix: 45 options available, 0 override(s) found [13:43:47] [main/INFO]: Applying Nashorn fix [13:43:47] [main/WARN]: Reference map 'NethersDelight-refmap.json' for nethersdelight.mixins.json could not be read. If this is a development environment you can ignore this message [13:43:47] [main/WARN]: Reference map 'fabric-the-lost-castle-refmap.json' for tlc.mixins.json could not be read. If this is a development environment you can ignore this message [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_459$class_462 (java.lang.ClassNotFoundException: net/minecraft/class_459$class_462) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_459$class_462 was not found amecs.mixins.json:ControlsListWidgetKeyBindingEntryAccessor from mod amecs [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_309 (java.lang.ClassNotFoundException: net/minecraft/class_309) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_309 was not found amecs.mixins.json:MixinKeyboard from mod amecs [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_638$class_5271 (java.lang.ClassNotFoundException: net/minecraft/class_638$class_5271) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_638$class_5271 was not found dust.mixins.json:ClientWorldAccessor from mod cavedust [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_293 (java.lang.ClassNotFoundException: net/minecraft/class_293) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_293 was not found creativecore.fabric.mixins.json:VertexFormatMixin from mod creativecore [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_5684 (java.lang.ClassNotFoundException: net/minecraft/class_5684) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_5684 was not found dehydration.mixins.json:TooltipComponentMixin from mod dehydration [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_906 (java.lang.ClassNotFoundException: net/minecraft/class_906) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_906 was not found go-fish.mixins.json:FishingBobberEntityRendererMixin from mod go-fish [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_702 (java.lang.ClassNotFoundException: net/minecraft/class_702) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_702 was not found go-fish.mixins.json:ParticleManagerMixin from mod go-fish [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_1007 (java.lang.ClassNotFoundException: net/minecraft/class_1007) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_1007 was not found inmis.mixins.json:client.PlayerEntityFeatureMixin from mod inmis [13:43:48] [main/WARN]: Error loading class: com/nhoryzon/mc/farmersdelight/block/TomatoBushCropBlock (java.lang.ClassNotFoundException: com/nhoryzon/mc/farmersdelight/block/TomatoBushCropBlock) [13:43:48] [main/WARN]: @Mixin target com.nhoryzon.mc.farmersdelight.block.TomatoBushCropBlock was not found jobsaddon.mixins.json:compat.TomatoBushCropBlockMixin from mod jobsaddon [13:43:48] [main/WARN]: Force-disabling mixin 'alloc.blockstate.StateMixin' as rule 'mixin.alloc.blockstate' (added by mods [ferritecore]) disables it and children [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_634 (java.lang.ClassNotFoundException: net/minecraft/class_634) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_634 was not found modernfix-fabric.mixins.json:core.ClientPlayNetHandlerMixin from mod modernfix [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_340 (java.lang.ClassNotFoundException: net/minecraft/class_340) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_340 was not found modernfix-fabric.mixins.json:feature.branding.GuiMixin from mod modernfix [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_1043 (java.lang.ClassNotFoundException: net/minecraft/class_1043) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_1043 was not found modernfix-fabric.mixins.json:safety.DynamicTextureMixin from mod modernfix [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_525 (java.lang.ClassNotFoundException: net/minecraft/class_525) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_525 was not found modernfix-common.mixins.json:perf.dedicated_reload_executor.CreateWorldScreenMixin from mod modernfix [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_7196 (java.lang.ClassNotFoundException: net/minecraft/class_7196) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_7196 was not found modernfix-common.mixins.json:perf.dedicated_reload_executor.WorldOpenFlowsMixin from mod modernfix [13:43:48] [main/WARN]: Error loading class: fr/catcore/server/translations/api/resource/language/SystemDelegatedLanguage (java.lang.ClassNotFoundException: fr/catcore/server/translations/api/resource/language/SystemDelegatedLanguage) [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_4224 (java.lang.ClassNotFoundException: net/minecraft/class_4224) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_4224 was not found sound_physics_remastered.mixins.json:ChannelAccessor from mod sound_physics_remastered [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_471 (java.lang.ClassNotFoundException: net/minecraft/class_471) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_471 was not found stendhal.mixins.json:AnvilScreenMixin from mod stendhal [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_473 (java.lang.ClassNotFoundException: net/minecraft/class_473) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_473 was not found stendhal.mixins.json:BookEditScreenMixin from mod stendhal [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_3872 (java.lang.ClassNotFoundException: net/minecraft/class_3872) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_3872 was not found stendhal.mixins.json:BookScreenMixin from mod stendhal [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_408 (java.lang.ClassNotFoundException: net/minecraft/class_408) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_408 was not found stendhal.mixins.json:ChatScreenMixin from mod stendhal [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_498 (java.lang.ClassNotFoundException: net/minecraft/class_498) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_498 was not found stendhal.mixins.json:SignEditScreenMixin from mod stendhal [13:43:48] [main/WARN]: Error loading class: net/minecraft/class_465 (java.lang.ClassNotFoundException: net/minecraft/class_465) [13:43:48] [main/WARN]: @Mixin target net.minecraft.class_465 was not found trinkets-curios-theme.mixins.json:HandledScreenMixin from mod trinkets-curios-theme [13:43:48] [main/WARN]: Error loading class: org/jetbrains/annotations/ApiStatus$Internal (java.lang.ClassNotFoundException: org/jetbrains/annotations/ApiStatus$Internal) [13:43:48] [main/WARN]: Error loading class: org/jetbrains/annotations/ApiStatus$Internal (java.lang.ClassNotFoundException: org/jetbrains/annotations/ApiStatus$Internal) [13:43:48] [main/WARN]: Error loading class: org/jetbrains/annotations/ApiStatus$Internal (java.lang.ClassNotFoundException: org/jetbrains/annotations/ApiStatus$Internal) [13:43:49] [main/INFO]: I used the json to destroy the json [13:43:49] [main/INFO]: Initializing MixinExtras via com.llamalad7.mixinextras.service.MixinExtrasServiceImpl(version=0.3.5). [13:43:50] [main/INFO]: Mixing server.MixinPlayer from nochatreports.mixins.json into net.minecraft.class_1657 [13:43:50] [main/WARN]: @Final field field_6280:Ljava/util/Map; in vinery.mixins.json:LivingEntityMixin from mod vinery should be final [13:43:51] [main/WARN]: Method overwrite conflict for compatSync in environmentz.mixins.json:ServerPlayerEntityMixin from mod environmentz, previously written by net.dehydration.mixin.ServerPlayerEntityMixin. Skipping method. [13:43:51] [main/WARN]: Method overwrite conflict for method_21740 in modernfix-common.mixins.json:perf.remove_biome_temperature_cache.BiomeMixin from mod modernfix, previously written by me.jellysquid.mods.lithium.mixin.world.temperature_cache.BiomeMixin. Skipping method. [13:43:51] [main/ERROR]: Minecraft has crashed! net.fabricmc.loader.impl.FormattedException: java.lang.NoSuchFieldError: CLIENT_CONFIG         at net.fabricmc.loader.impl.FormattedException.ofLocalized(FormattedException.java:63) ~[fabric-loader-0.15.11.jar:?]         at net.fabricmc.loader.impl.game.minecraft.MinecraftGameProvider.launch(MinecraftGameProvider.java:472) ~[fabric-loader-0.15.11.jar:?]         at net.fabricmc.loader.impl.launch.knot.Knot.launch(Knot.java:74) [fabric-loader-0.15.11.jar:?]         at net.fabricmc.loader.impl.launch.knot.KnotServer.main(KnotServer.java:23) [fabric-loader-0.15.11.jar:?]         at net.fabricmc.loader.impl.launch.server.FabricServerLauncher.main(FabricServerLauncher.java:69) [fabric-loader-0.15.11.jar:?]         at net.fabricmc.installer.ServerLauncher.main(ServerLauncher.java:69) [server.jar:1.0.1] Caused by: java.lang.NoSuchFieldError: CLIENT_CONFIG         at org.betterx.bclib.config.Configs.<clinit>(Configs.java:12) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.BCLBiomeSettings.applyWithDefaults(BCLBiomeSettings.java:201) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.BCLBiome.<init>(BCLBiome.java:290) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.BCLBiome.<init>(BCLBiome.java:273) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.InternalBiomeAPI.wrapNativeBiome(InternalBiomeAPI.java:268) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.InternalBiomeAPI.wrapNativeBiome(InternalBiomeAPI.java:232) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.BiomeAPI.<clinit>(BiomeAPI.java:254) ~[bclib-2.1.7.jar:?]         at org.betterx.bclib.api.v2.levelgen.biomes.BCLBiomeRegistry.bootstrap(BCLBiomeRegistry.java:91) ~[bclib-2.1.7.jar:?]         at net.minecraft.class_5458.method_44104(class_5458.java:98) ~[server-intermediary.jar:?]         at net.minecraft.class_5458.method_30566(class_5458.java:105) ~[server-intermediary.jar:?]         at java.util.LinkedHashMap.forEach(LinkedHashMap.java:729) ~[?:?]         at net.minecraft.class_5458.<clinit>(class_5458.java:104) ~[server-intermediary.jar:?]         at net.minecraft.class_2378.<clinit>(class_2378.java:326) ~[server-intermediary.jar:?]         at net.minecraft.class_2966.method_12851(class_2966.java:50) ~[server-intermediary.jar:?]         at net.minecraft.server.Main.main(Main.java:98) ~[server-intermediary.jar:?]         at net.fabricmc.loader.impl.game.minecraft.MinecraftGameProvider.launch(MinecraftGameProvider.java:470) ~[fabric-loader-0.15.11.jar:?]         ... 4 more
    • i dont know what is cousing this i am creating my own private modpack to play with  a friend but for some reason less then a minute after loading in a world the games freezes becouse my memory is 99% used (the memory i allocated for minecraft to use)   i keep searching in the log but i cant find the couse cen some pls help my find it   i play in minecraft version 1.20.1 and forge version 47.2.32 log: https://drive.google.com/file/d/1HlCl6R_20LwEsgk4Z9Y84IPBUUorxcA9/view?usp=sharing
    • If you want to access Resource from Minecraft, use: ResourceLocation.withDefaultNamespace("potato"); or If you want to access Resource from your mod, use: ResourceLocation.fromNamespaceAndPath("your_mod_id", "your_key");
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.