Jump to content

MC Forge Error: Unable to load Maven meta-data


happycode_deniz

Recommended Posts

I'm getting an error identical to this one (and about 6 other threads across multiple forums/websites) but none of the suggestions worked (nor does the final solution apply to me, as it was some network card driver issue).

 

For context, we are teaching a "Java Programming with Minecraft" class. 2 weeks ago we installed JDK/JRE/Eclipse and Minecraft Forge on about a dozen laptops, to stress test a MC forge in-house server we setup. This occurred on the Admin accounts.

 

But we have students using a separate non-Admin Windows 10 account. In order to show students how it all works and be able to setup modding at home, we planned to walk them through the same exact installation process that we documented (in a powerpoint). On the very last step, after writing a batch file to setup the Eclipse workspace, we hit this issue when running it. Offline/outside class, we are still unable to figure out:

 

* What went wrong:
A problem occurred configuring root project 'Deniz_FlyingPigs'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not resolve net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT.
     Required by:
         :Deniz_FlyingPigs:unspecified
      > Could not resolve net.minecraftforge.gradle:ForgeGradle:2.2-SNAPSHOT.
         > Unable to load Maven meta-data from http://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/2.2-SNAPSHOT/maven-metadata.xml.
            > org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 27; Open quote is expected for attribute "lang" associated with an  element type  "html".

 

Attached is the full --stacktrace error log. Forge_Error_log.txt

 

The 1-line .bat file is also attached, but also here: 

gradlew setupDecompWorkspace && gradlew eclipse

 

The following things we tried did not work:

  1. Disabling Windows firewall
  2. Disabling Trend Micro "Protection Against Viruses & Spyware" for 30 mins
  3. Running the SetupWorkspace.bat file as admin
  4. Running a cmd as Admin and executing SetupWorkspace.bat with and without the --stacktrace option
  5. Deleting Eclipse, and all modding folders, all folders generated by gradle on the Admin account before re-running the process on the Student account

 

We have a number of theories such as:

  1. Some kind of shared resource, such as registry keys, were taken by the initial installation on the Admin account and is now blocking proper installation on another account
  2. We first documented the whole setup process using JDK and JRE 1.8.0_161 and the day of the class, Oracle happened to have updated it to .0_171. This minor difference could be the cause?
    1. I did download the .0_161 installer again and ran it - usually a Java installer will prompt to uninstall other versions/installations of Java but did not in this case, perhaps it only does that if it detects older versions? So I went back and re-pointed the two Environment Variables to the .0_161 directory instead of .0_171 but this did not yield a different result.
  3. Although Google searches have showed the opposite, perhaps having multiple installs of Eclipse/Forge across multiple Windows accounts simple does not work? I've found threads about Eclipse saying it's as simple as copy/pasting the Eclipse directory. As for Forge I could not find anything explicitly saying if it will or won't be a problem.


ANY advice, ideas, or suggestions would be greatly appreciated.

Setup workspace.bat

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.