Jump to content

Can't utilize JavaFX FXML as parent root


Mothcock
 Share

Recommended Posts

I'm trying to make my mod open a JavaFX menu and want the parent root to be based off of an FXML file.

 

This is my code. Just a simple JavaFX app mostly based off IntelliJ's premade template being ran off a thread.

import javafx.application.Application;
import javafx.fxml.FXMLLoader;
import javafx.scene.Parent;
import javafx.scene.Scene;
import javafx.stage.Stage;
import sun.reflect.CallerSensitive;

public class JavaFXTest extends Application implements Runnable {
    @CallerSensitive
    public void start(Stage primaryStage) throws Exception {
        Parent root = FXMLLoader.load(getClass().getResource("sample.fxml"));
        primaryStage.setTitle("Hello World");
        primaryStage.setScene(new Scene(root, 300, 275));
        primaryStage.show();
    }

    @Override
    public void run() {
        launch();
    }
}

 

However when I start the thread, it throws the following error.

[15:46:56] [Thread-13/WARN] [FML]: =============================================================
[15:46:56] [Thread-13/WARN] [FML]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML!
[15:46:56] [Thread-13/WARN] [FML]: Offendor: com/sun/javafx/application/LauncherImpl.abort(Ljava/lang/Throwable;Ljava/lang/String;[Ljava/lang/Object;)V
[15:46:56] [Thread-13/WARN] [FML]: Use FMLCommonHandler.exitJava instead
[15:46:56] [Thread-13/WARN] [FML]: =============================================================
Exception in thread "Thread-13" [15:46:56] [JavaFX Application Thread/INFO] [STDERR]: [com.sun.javafx.application.LauncherImpl:lambda$launchApplication1$161:865]: Exception in Application start method
[15:46:56] [JavaFX-Launcher/INFO] [STDERR]: [com.sun.javafx.application.LauncherImpl:launchApplication1:933]: Workaround until RT-13281 is implemented: keep toolkit alive
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: java.lang.RuntimeException: Exception in Application start method
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:917)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$154(LauncherImpl.java:182)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at java.lang.Thread.run(Thread.java:748)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: Caused by: java.lang.InternalError: CallerSensitive annotation expected at frame 1
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at sun.reflect.Reflection.getCallerClass(Native Method)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at javafx.fxml.FXMLLoader.getDefaultClassLoader(FXMLLoader.java:3066)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at javafx.fxml.JavaFXBuilderFactory.<init>(JavaFXBuilderFactory.java:87)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at javafx.fxml.FXMLLoader.<clinit>(FXMLLoader.java:1815)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at net.minecraft.myMod.JavaFXTest.start(JavaFXTest.java:14)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$161(LauncherImpl.java:863)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$174(PlatformImpl.java:326)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.PlatformImpl.lambda$null$172(PlatformImpl.java:295)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at java.security.AccessController.doPrivileged(Native Method)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.javafx.application.PlatformImpl.lambda$runLater$173(PlatformImpl.java:294)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	at com.sun.glass.ui.win.WinApplication.lambda$null$147(WinApplication.java:177)
[15:46:56] [Thread-13/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:748]: 	... 1 more

 

The problem appears to be caused from this line.

Parent root = FXMLLoader.load(getClass().getResource("sample.fxml"));

 

How would I be able to implement the FXML file to the parent root properly in Forge? This works just fine when I'm not in the Forge modding environment, and looking at the warning it appears to be conflicting with JavaFX.

 

All help is appreciated. Thank you.

Edited by Mothcock
Link to comment
Share on other sites

35 minutes ago, diesieben07 said:

In your @Mod class constructor (i.e. before you load any javafx classes!) do Launch.classLoader.addTransformerExclusion("com.sun.javafx."). That should fix it.

Tried this and unfortunately it doesn't appear to work. I also tried excluding "javafx." and that didn't work either. Produces the same exact error. Any suggestions?

Link to comment
Share on other sites

15 minutes ago, diesieben07 said:

So the System.exit reference is still there? If so then you are loading the JavaFX classes before calling that method. You need to ensure this.

static {
    Launch.classLoader.addTransformerExclusion("javafx.");
    Launch.classLoader.addTransformerExclusion("com.sun.javafx.");
}

I have this in my mod's main class. Anything I could be doing wrong?

Link to comment
Share on other sites

You did not answer my question.

2 hours ago, Mothcock said:

[15:46:56] [Thread-13/WARN] [FML]: ============================================================= [15:46:56] [Thread-13/WARN] [FML]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML! [15:46:56] [Thread-13/WARN] [FML]: Offendor: com/sun/javafx/application/LauncherImpl.abort(Ljava/lang/Throwable;Ljava/lang/String;[Ljava/lang/Object;)V [15:46:56] [Thread-13/WARN] [FML]: Use FMLCommonHandler.exitJava instead [15:46:56] [Thread-13/WARN] [FML]: =============================================================

Is this still there?

Link to comment
Share on other sites

26 minutes ago, diesieben07 said:

Why did you put @CallerSensitive on your method? 

I can't see anything that would break it otherwise.

I was thinking the exception suggested that I should have. Re-adding @Override produces the same outcome, no difference.

@SubscribeEvent
public void onKeyPressed(InputEvent.KeyInputEvent event) {
    int keyCode = Keyboard.getEventKey();
    if(Keyboard.KEY_C == keyCode) {
        Thread thread = new Thread(new JavaFXTest());
        thread.start();
    }
}

This is how the UI is initialized if that helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.