Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

What does this error mean?


AssassinHero
 Share

Recommended Posts

I am texturing my first block

I have textured it and entered the code for it

 

It isn't showing up so when I look in the run logs I see this error

2013-03-17 11:45:20 [iNFO] [sTDERR] java.io.IOException: Server returned HTTP response code: 503 for URL: http://s3.amazonaws.com/MinecraftResources/
2013-03-17 11:45:20 [iNFO] [sTDERR] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
2013-03-17 11:45:20 [iNFO] [sTDERR] 	at net.minecraft.util.ThreadDownloadResources.run(ThreadDownloadResources.java:57)

 

I can only assume that this is stopping the texture from being loaded...

 

Any help?!?!

STOP CRUCIFYING NEW MODDERS!!!!

Link to comment
Share on other sites

Has nothing to do with your texture. Minecraft downloads sounds, etc. when it first starts and when that fails that error is shown.

I guess the MC servers are just down.

 

This is my code for my texture..

public class BlockParallelWorldsBlock extends Block{

public BlockParallelWorldsBlock(int id, int texture, Material mat){
	super(id, mat);
	this.setCreativeTab(CreativeTabs.tabBlock);




	}
public String getTextureFile(){
	return "/parallelworlds/ParallelWorlds_Blcoks.png";
}



}



 

public class ClientProxyParallelWorlds extends CommonProxyParallelWorlds{

@Override
public void registerRenders() {
	MinecraftForgeClient.preloadTexture("/parallelworlds/ParallelWorlds_Blcoks.png");
}


}

 

@Mod(modid = "Parallel Worlds", name = "Parallel Worlds", version = "1.0.0")
@NetworkMod(clientSideRequired = true, serverSideRequired = false)
public class ParallelWorlds {

@SidedProxy(clientSide = "parallelworlds.client.ClientProxyParallelWorlds", serverSide = "parallelworlds.common.CommonProxyParallelWorlds")

public static ClientProxyParallelWorlds proxy = new ClientProxyParallelWorlds();

Block parallelworldsBlock;


int parallelworldsBlockID = 682;

@Init
public void load(FMLInitializationEvent event){
	parallelworldsBlock = new BlockParallelWorldsBlock(parallelworldsBlockID, 0, Material.iron).setUnlocalizedName("Nightium").setHardness(8.0F).setResistance(10000.0F).setStepSound(Block.soundStoneFootstep);
	gameRegisters();
	languageRegisters();
	proxy.registerRenders();
}


	public void gameRegisters(){
		GameRegistry.registerBlock(parallelworldsBlock);}

		public void languageRegisters(){

		LanguageRegistry.addName(parallelworldsBlock, "Nightium");

		}



}

 

Blocks is spelt Blcoks on purpose...

 

Any help on this?!

 

STOP CRUCIFYING NEW MODDERS!!!!

Link to comment
Share on other sites

he has update, he is using setUnlocalised name instead of setblockName

 

Then he should follow this tutorial regarding to the new texture system: http://www.minecraftforum.net/topic/1722368-15-icons-and-block-textures/

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.