Jump to content

[Solved] Unable to load maven meta from files.minecraftforge.tweak


Recommended Posts

So I just went back to work on a project after not working on it for a week (after being sick), I recall I was working normally like you usually do, and everything worked fine. I then took a break and worked on other projects, got sick half a week and now I was about to get back to that project. However I noticed the project had missing dependencies as soon as I launch IntelliJ. I decide I want to fix this, my first thought was to do gradlew setupDecompWorkspace as that's what I usually do right after I run git pull in case something happened in that manner. However I instantly get an error, which I will get to later.

I then try to look up the error, search a few times and can't find any relevant info. I did find people having similar problems but all solutions were the same, to run gradlew setupDecompWorkspace --refresh-dependencies or simply gradlew --refresh-dependencies, both of which I already knew of, and both also gave the same error as above. So the error I get when I ran that command is the following


D:\Root\Dropbox\Java\IntelliJ\Forge Modding\KirdowThrowsNull\MCMODS\ItemLocks>gradlew --refresh-dependencies
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/2.14/userguide/gradle_daemon.html.
FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'ItemLocks'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not resolve tweak.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT.
     Required by:
      > Could not resolve tweak.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT.
         > Unable to load Maven meta-data from http://files.minecraftforge.tweak/maven/tweak/minecraftforge/gradle/ForgeGradle/2.3-SNAPSHOT/maven-metadata.xml.
            > Could not GET 'http://files.minecraftforge.tweak/maven/tweak/minecraftforge/gradle/ForgeGradle/2.3-SNAPSHOT/maven-metadata.xml'.
               > files.minecraftforge.tweak

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 5.36 secs


I decided to search this forums for stuff, I searched for "Unable to load Maven meta-data from" which ended up giving tons of results, none of my interest

I then decided to search up "tweak.minecraftforge.gradle" which I found gave no result at all, and also "files.minecraftforge.tweak" which also gave no result.

At that point I felt I was clueless and had no idea, and decided to make this post.

Any idea?


EDIT: The console command is run from inside IntelliJ just so you're aware. Might look inconvenient otherwise

Edited by Kirdow
Link to comment
Share on other sites

Well that was pretty weird. So I realized I wrote about git pull so I decided to look in my git repo and commits, and found a strange thing where the commit where I made a custom ArrayList override called ListTweaker, there was a change to build.gradle which changed all net to tweak which I have no idea how that could happen (since I'm the only one on this project), I'm guessing some select all or similar action happened which searched all files by mistake. Nothing major, everything sorted out. Gonna add [Solved] to title

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.