Jump to content

Code Isn't Running In 1.8.9 All Software Is Up To Date, What Is The Problem


Recommended Posts

I was following Powns' tutorial


on how to make mods in Minecraft 1.8.9 Forge.

I did the exact same thing as him but when I ran it, it did not work. This has lead me to believe that it has to do with my JDK version. Except, he does not say which one he uses, what version should I use?

I have tried using the newest version and it does not work, I'm using 8u5 currently.

My code for the counter is

package me.BeastModeGamez.arrowCounter;

import net.minecraft.init.Blocks;
import net.minecraftforge.fml.common.Mod;
import net.minecraftforge.fml.common.Mod.EventHandler;
import net.minecraftforge.fml.common.event.FMLInitializationEvent;

@Mod(modid = ArrowCounter.MODID, version = ArrowCounter.VERSION)
public class ArrowCounter
    public static final String MODID = "arrowCounter";
    public static final String VERSION = "1.0";

    public void init(FMLInitializationEvent event)


My code for the counterCommands is

package me.BeastModeGamez.arrowCounter.commands;

import net.minecraft.command.CommandBase;
import net.minecraft.command.CommandException;
import net.minecraft.command.ICommandSender;
import net.minecraft.util.ChatComponentText;

public class arrowCounterCommands extends CommandBase {

    public String getCommandName() {
    return "arrowcounter";

    public String getCommandUsage(ICommandSender sender) {
        return "/" + getCommandName();

    public void processCommand(ICommandSender sender, String[] args) throws CommandException {
        sender.addChatMessage(new ChatComponentText("Test Command."));


    public int getRequiredPermissionLevel() {
        return 0;

    public boolean canCommandSenderUseCommand(final ICommandSender p_71519_1_) {
    return true;


I hope to see the mod work, but instead it says unknown command. Something that I believe to be important are two warnings saying:

Description Resource Path Location Type The compiler compliance specified is 1.6 but a JRE 1.8 is used .org.eclipse.jdt.core.external.folders Compiler Compliance JRE Compiler Compliance Problem

and also

Description Resource Path Location Type The compiler compliance specified is 1.6 but a JRE 1.8 is used MDKExample Compiler Compliance JRE Compiler Compliance Problem

Also, in case you are wondering if the code won't work anymore, the video was made 3 weeks ago.

So, in conclusion, my question is: what is needed to fix this, and does it have to do with the JRE as it says in the warnings, or is my code incorrect, or do I need a newer JDK? And if I do have to change the JRE, how?


Edit: I have fixed both errors and it is still not working... Which means it most likely doesn't have to do with software and my code is wrong... but whats wrong?

Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.