Jump to content

Task 'setupDecompWorkspace' not found in root project 'testmod'.


3nt3

Recommended Posts

I'm new to mod development and this is my first attempt. I am new so I followed along the "Getting Started" guide on the forge documentation. I downloaded the mdk zip and copied "build.gradle", "gradlew", "gradle/" and "gradle.properties" to a new folder.

I opened a shell and ran 

./gradlew setupDecompWorkspace

It failed with following exception:

Task 'setupDecompWorkspace' not found in root project 'testmod'.

 

I am on mac and using IntelliJ IDEA

 

Edited by 3nt3
add information
Link to comment
Share on other sites

1 minute ago, diesieben07 said:

1.13 is still quite new, so the Getting Started guide has not been updated. You do not need to run setupDecompWorkspace anymore, simply import the project.

Thank you!

I tried using 1.8 now. I ran the same command and now it fails with following exception:

Could not determine java version from '11.0.1'.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.