Jump to content

Custom sun texture not being rendered


Dizzlepop12

Recommended Posts

I have a custom sun for one of my dimensions, but it appears as a gigantic purple square in the sky instead of the texture that it's bound to. Not sure what the problem is, but the resource location is correct and I can't find any reason why is shouldn't be rendering. Any suggestions?

 

SkyRenderer: https://github.com/TheSlayerMC/Journey-1.12/blob/master/main/java/net/journey/dimension/BoilSkyRenderer.java#L120

Resource Location: https://github.com/TheSlayerMC/Journey-1.12/tree/master/main/resources/assets/journey/textures/environment

Edited by Dizzlepop12
Link to comment
Share on other sites

Have you stepping through your code with the debugger?

Edited by Cadiboo

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

 

17 hours ago, Cadiboo said:

Have you stepping through your code with the debugger?

I'm pretty new to using the debugger. I set it up in my SkyRenderer class where I think it should go, and I'm not sure where I go from here.

In the console, I keep getting this error: 

[11:31:24] [main/ERROR] [minecraft/Minecraft]: ########## GL ERROR ##########
[11:31:24] [main/ERROR] [minecraft/Minecraft]: @ Post render
[11:31:24] [main/ERROR] [minecraft/Minecraft]: 1281: Invalid value

But I'm not sure if it has any relation to the SkyRenderer class.

Here's where my debugger is: debugger

Edited by Dizzlepop12
Link to comment
Share on other sites

That’s not a debugger. That’s a profiler. 

https://www.eclipse.org/community/eclipse_newsletter/2017/june/article1.php

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.