Jump to content

Forge 1.13.2 crashing on Linux only (Windows is fine) [SOLVED]


Recommended Posts

I spent some time trying to figure this out last night, and made very little progress. I'm not sure what my next steps are, but I hope this information is useful to someone:


  • 1.13.2-forge-25.0.146 crashes on two separate Linux machines, but runs just fine on my Windows machine. The most obvious difference between the two, other than Windows vs Linux, is that the Windows machine uses Oracle Java and the Linux machines use openjdk
  • Here is a pastebin for the lastest log file: https://pastebin.com/Dr1V0QQZ
  • No crash report is generated when this crash occurs (the last crash-reports file I have in my directory has a timestamp of 2019-04-06)
  • This current log file is for a machine that has plugins loaded in it, but on my other Linux machine I deleted all my plugins and still got a crash.
  • I can load vanilla 1.13.2 (no Forge) and it works fine
  • Attempting to "back out" to a lower version of Forge still causes a crash. I suspect, though, that in that case I simply don't know how to clean up my minecraft environment properly.
  • This is an observation only (so perhaps unreliable), but when I first installed .146 and fired it up in the launcher, it started downloading the extra files it needed, and the window closed before the progress bar indicated it was finished. A few seconds later the crash dialog came up. Ever since then, the crash dialog appears almost immediately after I click the launch button. So I wondered if perhaps it hadn't finished downloading the extra components it needs? Not sure how to verify that, though. If there's a way to get that information to you I'm happy to do so, I just need someone to tell me how.
Edited by CBWright
Issue solved
Link to comment
Share on other sites

It's because Forge doesn't support newer versions of Java. I suspect you probably have OpenJDK 11 or OpenJDK 12. You'll have to download an older Java runtime, then point Foge to it.


I had luck with the files here: https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html


Get the Linux x64 tar.gz file and extract it somewhere. Then go to the profile settings for Forge and change the Java executable to the older one. I think you need to enable advanced settings.

Edited by treebranch
  • Thanks 1
Link to comment
Share on other sites

Yep, that was the problem! I had both OpenJDK 11 and 8 installed on my machine. In the past Minecraft always defaulted to using 8 so I never really thought about it.


I removed 11 and Minecraft with Forge runs fine. So now that I know that, when I get home I'll take treebranch's advice, to into the settings on my other machine, and configure minecraft to use the v8 executable, see how that goes.

  • Thanks 1
Link to comment
Share on other sites

Is there a way to close/mark a thread as resolved? I was finally able to confirm last night that, as per treebranch's suggestion, I could simply configure each individual entry in the minecraft launcher to point to the openjdk 8 executable in /usr/lib and it launched fine, even with openjdk 11 installed as well. So this issue is now completely and thoroughly a non-issue. ?


Thanks all.

Link to comment
Share on other sites

Best way is to just edit the thread title and put [SOLVED] at the beginning.

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.