Jump to content

MDK 1.13.2 setup problems


oHomer

Recommended Posts

I want to setup a forge workspace but I get the following error text every time I try any kind of gradlew command:


---------------------------
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'Workspace 1.13'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not resolve net.minecraftforge.gradle:ForgeGradle:3.+.
     Required by:
         project :
      > Failed to list versions for net.minecraftforge.gradle:ForgeGradle.
         > Unable to load Maven meta-data from https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml.
            > Could not get resource 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.
               > Could not GET 'https://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGradle/maven-metadata.xml'.
                  > Received fatal alert: handshake_failure
--------------------


I try to fix it by using another JDK (jdk7u80;jdk8u211;jdk 11.0.3) or another computer(Win7Pro64bit;Win10Pro64bit) but nothing helps. Changing the network/place also makes no difference, as well as deactivating the Firewall, Avira or the Java security system. The web adress in the code is accessible with my browser.

Have someone an idea what is the issue?
 

Link to comment
Share on other sites

I had a similar problem. I installed jdk1.8.0_201 and it all worked. Specifically, my problem was related to the gradle and jdk version. If you follow the recommendations of gradle and run other commands, it should write what the problem is. Be sure to fix the %PATH%.

Edited by Torq

If I helped you, don't forget like. I'm using a translator, sorry.

Link to comment
Share on other sites

7 hours ago, oHomer said:

Received fatal alert: handshake_failure

You need to be able to download files from forge files from the internet. Make sure that your antivirus allows access to forge and that access to forges maven is not blocked by a proxy or your internet settings. 

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

I ran into this problem too, make sure you're using the latest Java 8 JDK and MAKE SURE JAVA_HOME IS SET PROPERLY. Gradle uses the JDK from JAVA_HOME, not the one on your PATH. Specifically, this happens because Java only got support for Let's Encrypt certificates around jdk8_u100 and Forge uses Let's Encrypt.

Edited by NuclearFarts
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.