Jump to content

Forge jar Runs, but Doesn't Open Anything/Crashes


Ash White

Recommended Posts

Hello,

I have been trying to switch a vanilla server over to a forge modded server with the intent of only installing server-side mods. My issue is that when I double click the forge jar I get a loading blue circle for a few seconds and then nothing happens. Below are the stack trace and log for this error, as well as what I have tried and what I know.

 

I have uninstalled and reinstalled forge-1.14.2-26.0.62 four-six times, every time it would download and set up the necessary files, then I would start the minecraft server jar and it would set up its files, and I agreed to the EULA, then I could not get the forge jar file to run. I have also tried it with running the Minecraft server jar first on a fresh install. When I double-click the Minecraft server jar file it runs and I get the terminal, but when loaded it appears that forge is working but only one mod functions out of three. The forge-based clients can connect as well, and they can play without any problems, but again two mods don't function. At the moment, I am unsure whether forge or the mods are at fault, but when reviewing the logs and stack trace it doesn't seem to have a definitive answer, but I only barely know how to read them. I do know that there haven't been reported issues with the two mods that are failing with their 1.14.2 versions. They also don't appear as loaded and  /"modname" does not do anything.

 

For reference, I am using Java version 1.8.0_211.

 

I have googled the visible error marks on the stack trace and tried to find relevant forums and have failed, as most issues were related to something else, such as the Java version being wrong, or the EULA still being marked false. Also, I have tried to start it using a .bat file but that seemed to only make it worse. My current guess is that forge isn't being loaded at all, but I am unsure how to fix this issue.

 

Thanks, in advance.

 

Stack Trace

Spoiler

C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns>java -jar forge-1.14.2-26.0.62.jar
2019-07-28 01:57:41,184 main ERROR Error processing element Queue ([Appenders: null]): CLASS_NOT_FOUND
2019-07-28 01:57:41,239 main WARN Disabling terminal, you're running in an unsupported environment.
2019-07-28 01:57:41,289 main ERROR Unable to locate appender "ServerGuiConsole" for logger config "root"
[01:57:41.333] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 26.0.62, --fml.mcpVersion, 20190603.175704, --fml.mcVersion, 1.14.2, --fml.forgeGroup, net.minecraftforge]
mainEx[01:57:41.336] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_211 by Oracle Corporation
mainEx[01:57:41.634] [main/INFO] [ne.mi.fm.lo.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
mainExException in thread "main" [01:57:41.690] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: java.lang.NullPointerException
mainEx[01:57:41.691] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.fml.loading.LibraryFinder.findLibsPath(LibraryFinder.java:41)
mainEx[01:57:41.693] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.fml.loading.LibraryFinder.getForgeLibraryPath(LibraryFinder.java:71)
mainEx[01:57:41.693] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.fml.loading.FMLCommonLaunchHandler.getForgePath(FMLCommonLaunchHandler.java:62)
mainEx[01:57:41.693] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.fml.loading.FMLLoader.setupLaunchHandler(FMLLoader.java:182)
mainEx[01:57:41.694] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.fml.loading.FMLServiceProvider.initialize(FMLServiceProvider.java:82)
mainEx[01:57:41.694] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:61)
mainEx[01:57:41.694] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$5(TransformationServicesHandler.java:91)
mainEx[01:57:41.695] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at java.util.HashMap$Values.forEach(HashMap.java:981)
mainEx[01:57:41.695] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:91)
mainEx[01:57:41.695] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:52)
mainEx[01:57:41.695] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.Launcher.run(Launcher.java:72)
mainEx[01:57:41.696] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at cpw.mods.modlauncher.Launcher.main(Launcher.java:62)
mainEx[01:57:41.696] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
mainEx[01:57:41.696] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
mainEx[01:57:41.696] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]:     at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)
mainEx

 

 

Log

Spoiler

[28Jul2019 00:58:30.264] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 26.0.62, --fml.mcpVersion, 20190603.175704, --fml.mcVersion, 1.14.2, --fml.forgeGroup, net.minecraftforge]
[28Jul2019 00:58:30.267] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_211 by Oracle Corporation
[28Jul2019 00:58:30.580] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
[28Jul2019 00:58:30.641] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NullPointerException
[28Jul2019 00:58:30.641] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.LibraryFinder.findLibsPath(LibraryFinder.java:41)
[28Jul2019 00:58:30.644] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.LibraryFinder.getForgeLibraryPath(LibraryFinder.java:71)
[28Jul2019 00:58:30.644] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLCommonLaunchHandler.getForgePath(FMLCommonLaunchHandler.java:62)
[28Jul2019 00:58:30.644] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLLoader.setupLaunchHandler(FMLLoader.java:182)
[28Jul2019 00:58:30.645] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLServiceProvider.initialize(FMLServiceProvider.java:82)
[28Jul2019 00:58:30.645] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:61)
[28Jul2019 00:58:30.645] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$5(TransformationServicesHandler.java:91)
[28Jul2019 00:58:30.645] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at java.util.HashMap$Values.forEach(Unknown Source)
[28Jul2019 00:58:30.646] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:91)
[28Jul2019 00:58:30.646] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:52)
[28Jul2019 00:58:30.646] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.run(Launcher.java:72)
[28Jul2019 00:58:30.646] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.main(Launcher.java:62)
[28Jul2019 00:58:30.647] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
[28Jul2019 00:58:30.647] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
[28Jul2019 00:58:30.647] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)

 

 

 

Debug Log

Spoiler

[26Jul2019 17:29:01.799] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 26.0.62, --fml.mcpVersion, 20190603.175704, --fml.mcVersion, 1.14.2, --fml.forgeGroup, net.minecraftforge]
[26Jul2019 17:29:01.802] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_211 by Oracle Corporation
[26Jul2019 17:29:01.808] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver]
[26Jul2019 17:29:01.815] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : []
[26Jul2019 17:29:01.824] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [eventbus,object_holder_definalize,runtime_enum_extender,field_redirect_net.minecraft.potion.PotionEffect/Lnet/minecraft/potion/Potion;,accesstransformer,capability_inject_definalize,runtimedistcleaner]
[26Jul2019 17:29:01.838] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services
[26Jul2019 17:29:01.844] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Found additional transformation services from discovery services: []
[26Jul2019 17:29:01.855] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Found transformer services : [fml]
[26Jul2019 17:29:01.855] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Transformation services loading
[26Jul2019 17:29:01.855] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loading service fml
[26Jul2019 17:29:01.856] [main/DEBUG] [net.minecraftforge.fml.loading.FMLServiceProvider/]: Injecting tracing printstreams for STDOUT/STDERR.
[26Jul2019 17:29:01.858] [main/DEBUG] [net.minecraftforge.fml.loading.LauncherVersion/CORE]: Found FMLLauncher version 26.0
[26Jul2019 17:29:01.858] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML 26.0 loading
[26Jul2019 17:29:01.858] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found ModLauncher version : 2.1.4+53+1f9473a
[26Jul2019 17:29:01.859] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Initializing modjar URL handler
[26Jul2019 17:29:01.859] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found AccessTransformer version : 0.16.0+44+853b469
[26Jul2019 17:29:01.859] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found EventBus version : 0.10.1+43+294f1ae
[26Jul2019 17:29:01.860] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found Runtime Dist Cleaner
[26Jul2019 17:29:01.864] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found CoreMod version : 0.5.0+21+fd93452
[26Jul2019 17:29:01.864] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found ForgeSPI package implementation version 0.13.0+25+9048a81
[26Jul2019 17:29:01.864] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found ForgeSPI package specification 2
[26Jul2019 17:29:02.100] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
[26Jul2019 17:29:02.101] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loaded service fml
[26Jul2019 17:29:02.103] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Configuring option handling for services
[26Jul2019 17:29:02.111] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Transformation services initializing
[26Jul2019 17:29:02.112] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Initializing transformation service fml
[26Jul2019 17:29:02.112] [main/DEBUG] [net.minecraftforge.fml.loading.FMLServiceProvider/CORE]: Setting up basic FML game directories
[26Jul2019 17:29:02.113] [main/DEBUG] [net.minecraftforge.fml.loading.FileUtils/CORE]: Found existing GAMEDIR directory : C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns
[26Jul2019 17:29:02.113] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns
[26Jul2019 17:29:02.113] [main/DEBUG] [net.minecraftforge.fml.loading.FileUtils/CORE]: Found existing MODSDIR directory : C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\mods
[26Jul2019 17:29:02.113] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\mods
[26Jul2019 17:29:02.114] [main/DEBUG] [net.minecraftforge.fml.loading.FileUtils/CORE]: Making CONFIGDIR directory : C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\config
[26Jul2019 17:29:02.114] [main/DEBUG] [net.minecraftforge.fml.loading.FileUtils/CORE]: Created CONFIGDIR directory : C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\config
[26Jul2019 17:29:02.114] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\config
[26Jul2019 17:29:02.115] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\config\fml.toml
[26Jul2019 17:29:02.115] [main/DEBUG] [net.minecraftforge.fml.loading.FMLServiceProvider/CORE]: Loading configuration
[26Jul2019 17:29:02.153] [main/TRACE] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Loaded FML config from C:\Users\ashka\Servers\Minecraft\!Vanilla For Reals\The Prodigal Son Returns\config\fml.toml
[26Jul2019 17:29:02.154] [main/TRACE] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Splash screen is true
[26Jul2019 17:29:02.154] [main/TRACE] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Max threads for mod loading computed at 12
[26Jul2019 17:29:02.154] [main/TRACE] [net.minecraftforge.fml.loading.FMLConfig/CORE]: Version check is true
[26Jul2019 17:29:02.154] [main/DEBUG] [net.minecraftforge.fml.loading.FMLServiceProvider/CORE]: Preparing launch handler
[26Jul2019 17:29:02.155] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Using fmlserver as launch service
[26Jul2019 17:29:02.157] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Received command line version data  : MC Version: '1.14.2' MCP Version: '20190603.175704' Forge Version: '26.0.62' Forge group: 'net.minecraftforge'
[26Jul2019 17:29:02.158] [main/DEBUG] [net.minecraftforge.fml.loading.LibraryFinder/CORE]: Found JAR asm at path C:\Users\ashka\Servers\Minecraft
[26Jul2019 17:29:02.159] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NullPointerException
[26Jul2019 17:29:02.160] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.LibraryFinder.findLibsPath(LibraryFinder.java:41)
[26Jul2019 17:29:02.160] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.LibraryFinder.getForgeLibraryPath(LibraryFinder.java:71)
[26Jul2019 17:29:02.160] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLCommonLaunchHandler.getForgePath(FMLCommonLaunchHandler.java:62)
[26Jul2019 17:29:02.161] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLLoader.setupLaunchHandler(FMLLoader.java:182)
[26Jul2019 17:29:02.161] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.fml.loading.FMLServiceProvider.initialize(FMLServiceProvider.java:82)
[26Jul2019 17:29:02.161] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:61)
[26Jul2019 17:29:02.161] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$5(TransformationServicesHandler.java:91)
[26Jul2019 17:29:02.162] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at java.util.HashMap$Values.forEach(Unknown Source)
[26Jul2019 17:29:02.162] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:91)
[26Jul2019 17:29:02.162] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:52)
[26Jul2019 17:29:02.162] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.run(Launcher.java:72)
[26Jul2019 17:29:02.163] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.main(Launcher.java:62)
[26Jul2019 17:29:02.163] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63)
[26Jul2019 17:29:02.163] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60)
[26Jul2019 17:29:02.163] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at net.minecraftforge.server.ServerMain.main(ServerMain.java:57)

 

 

Link to comment
Share on other sites

First I would suggest updating to 1.14.4

Second you should change the name of one of your folders, exclamation points have special meaning in Java and they mess with file paths

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

I would update to 1.14.4 but the mods I am using aren't updated to that version yet. Also, thank you so much it appears the exclamation point was the issue! Very frustrating but I am learning code at the moment so I should have known better, again thanks a lot!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.