Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Adding a mod


6HD
 Share

Recommended Posts

Sorry if this has been asked 100 times I done a quick search but couldn't find alot.

 

I notice once I start Minecraft that under the Mod section is 'Forge Mod Loader'. Can this be used to add mods to a server? If so how can this be done?

 

Thank you.

 

Edit: I've got the server up and running, I'm just not sure how Mods are added :)

Link to comment
Share on other sites

So there are 2 options:

*ModLoader (Oldschool - still god but just different than Forge)

*Forge

So I guess you are using Forge.

Forge is an API that have alredy implemented FML (ForgeModLoader) which is nearly the same as normal ModLoader. This allows you to add mods on your client and server.

How to install mods:

1. Get minecraft_server.jar (1.5.1)

2. Get NEW (clean) .minecraft (delete one in AppData and download new one)

3. Go here: http://www.minecraftforge.net/forum/index.php?action=files

4. Download *universal* - be sure to download lates version.

5. Open minecarft.jar and minecraft_server.jar and put downloaded forge in it. (NOTE: You only need Forge as it alredy has ModLoader in it, no nooed to instal ML separately)

6. Now only one thing you need to do is install mods:

-You'll need to find mod you want to install (be sure it's SMP and has 1.5.1 FORGE support)

-Most of mods are *Universal*, and if so, only one thing you'll need to do is put mod .zip (or .jar) file into:

/.minecarft/mods/

and

/server/mods/

-Launche the server and log in.

 

-If mod isn't universal you just download Server Forge version of it, and Client Forge version.

client v. in client.

server v. in server.

 

 

 

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

If you are running forge with mods, all players playing there would have to download your mod pack (or use your launcher, which I guess you don't have - don't ask how to get one - this is rather for big servers or coder that have time to code one).

 

So basically - yes, they need to have all mods included in /mods/ directory of server.

Btw.: You can also drop (unpack) .zip/.jar mod into minecarft.jar (also server) - this would help you if you are going to distribute your modpack (only it you are not using mods that have they own resources)

Also remember to ask author about redistributing his mod - ALWAYS.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.