Jump to content

[SOLVED] [1.12.2] Accessing ops.json file crashes client


Recommended Posts



I've been trying to OP a player with a specified permission level. So I just copied the code from PlayerList::addOp(GameProfile profile); and just tweaked the permission level. However, when I log on a dedicated server, the client crashes.
Code  blocks: https://pastebin.com/cjekvJU8

Note: in the paste, SERVER is FMLCommonHandler.instance().getMinecraftServerInstance();

Crash report: https://pastebin.com/xi9itUPp

I guess it's because I'm accessing ops.json in the wrong way. If so, how would I access it to add an entry with a custom permission level??

Any help is appreciated. If you need more code, please let me know.




EDIT 1: Getting MinecraftServer instance from EntityLivingBase::getServer(); and instead of making an instance for the file, I access it from PlayerList.FILE_OPS. No crash report. Going to try custom command.

EDIT 2: The command doesn't work. Is there anything I'm doing wrong? Am I not allowed to OP a player to an integer less than the OP permission level?

EDIT 3: Oh oops, I'm creating a new instance of UserListOps...

EDIT 4: Solved.

Edited by Differentiation
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.