Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.14.4-28.1.1] Cannot Resolve Dependencies after setup


KeldonSlayer
 Share

Recommended Posts

Okay, so after following a few guides on the new setup process, I like it, if it worked for me.
Using

  • JetBrains IntelliJ IDEA 2019.2.2
  • Minecraft 1.14.4
  • Forge 28.1.1
  • Included Gradle Wrapper (my installed gradle is 5.6.0)

I ran the Following Steps

  • Created Folder in non-UAC folder
  • git cloned my project from my own github group for a 1.14.4 mod we were working on This Mod < Linked mod so you can view the build.gradle
  • opened intellij and imported existing project from build.gradle
    • Checked auto import and changed to wrapper
  • Waited for intellij to setup indexing and gradle imports
  • then ran fg_runs/genIntelliJRuns

 

I get the following error

Spoiler

X:\MyPrograms\JetBrains\IntelliJ IDEA 2019.2.2\jbr\bin\Could not find net.minecraftforge:forge:1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.
Searched in the following locations:
  - https:\jcenter.bintray.com\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.pom
  - https:\jcenter.bintray.com\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.jar
  - file:\C:\Users\kyahn\.gradle\caches\forge_gradle\bundeled_repo\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.pom
  - file:\C:\Users\kyahn\.gradle\caches\forge_gradle\bundeled_repo\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.jar
  - https:\files.minecraftforge.net\maven\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.pom
  - https:\files.minecraftforge.net\maven\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.jar
  - https:\libraries.minecraft.net\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.jar
  - https:\repo.maven.apache.org\maven2\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.pom
  - https:\repo.maven.apache.org\maven2\net\minecraftforge\forge\1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea\forge-1.14.4-28.1.1_mapped_snapshot_20190913-1.14.3_at_455d784fa1e20189e22047acb209229e71dae2ea.jar

Yes I see my user path is there, no I don't care

Is the issue caused by separate drives?
my C Drive is ssd and small af (2.3GB free at most)

X Drive is where I store all my dev enviroments, and my Windows Libraries (Downloads/Documents/Pictures/Videos/Music)

I feel as if I overlooked something, since I am sleep deprived (3 hours of sleep in last 48 hours). But I've developed a few mods, a game, mods for 7 games in total, and with knowledge of 6 coding languages. Yet I cannot solve a simple issue that appears to not be common enough to have an easily google searchable fix... I feel useless right now.

Edited by KeldonSlayer
Added link to github
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i did it in 1.12.2 not walking for me can anyone help me get it pls???  
    • Got the rotation working. I had to look at LivingEntityRenderer#render and setupRotations a little more closely, and I realized that I needed to change the custom entity's yBodyRot and yBodyRotO.  private static boolean renderingCustomEntity = false; private static CustomEntity customEntity; private static void refreshCustomEntity(LocalPlayer localPlayer, LivingEntity livingEntity) { if (customEntity == null || customEntity.isRemoved()) { customEntity = ModEntities.CUSTOM_ENTITY.get().create(localPlayer.clientLevel); } if (!customEntity.level.dimension().equals(livingEntity.level.dimension())) { customEntity.discard(); } } @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { LocalPlayer localPlayer = Minecraft.getInstance().player; if (localPlayer != null && event.getEntity() instanceof Mob mob) { if (/* put your own condition here */) { if (!renderingCustomEntity) { try { renderingCustomEntity = true; event.setCanceled(true); refreshCustomEntity(localPlayer, mob); // (truth be told, my custom entity does not have a "head", so these lines aren't needed) // customEntity.setYHeadRot(mob.getYHeadRot()); // customEntity.yHeadRotO = mob.yHeadRotO; customEntity.setYBodyRot(mob.yBodyRot); customEntity.yBodyRotO = mob.yBodyRotO; customEntity.setPose(mob.getPose()); Minecraft.getInstance().getEntityRenderDispatcher().getRenderer(customEntity).render( customEntity, customEntity.yBodyRot, event.getPartialTick(), event.getPoseStack(), event.getMultiBufferSource(), event.getPackedLight() ); } finally { renderingCustomEntity = false; } } } } }   As shown in my code, if the mob whose model is replaced moves to a different dimension, I unload the custom entity with Entity#discard and then reinitialize it on the next tick. I wonder if I also have to unload the custom entity when the mob it is "replacing" dies.
    • Thank you for the video, but I found the issue. I had to update the Gradle from 7.2 to 7.3 in gradle/wrapper/gradle-wrapper.properties.
    • Some zip managers like to take control of the .jar file extension away from Java. Make sure you have Java installed and try running Jarfix once, then try the installer again.
    • Whenever i try and download forge specifically 1.18.2 it will download as a JAR file as a note page and theirs no way to install it i have watched a few videos but none show how to fix this problem
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.