Jump to content

[Solved][1.12.2]Item Model not showing [Item different when in hand and in GUI]


DeathSpawn

Recommended Posts

In my mod, I implemented a custom IBakedModel class based on the discussion here

But the problem is, both my item in GUI and in hand are not showing. The item in hand is just a missing texture whereas my GUI texture is invisible.

 

My Github Repo is located here: https://github.com/SSJDeathSpawnMod/Rising-of-the-Shield-Hero-Mod

 

I think it has something to do with

if(!(model instanceof IFlexibleBakedModel)) model = new IFlexibleBakedModel.Wrapper(model, DefaultVertexFormats.ITEM);

since I do not know of the 1.12.2 equivalent.

 

Any help is appreciated.

Edited by DeathSpawn
It's solved :)
Link to comment
Share on other sites

I wrote the code with changing models on whether it held in hand or in any other perspectives in mind

The (failed) result:

image.png.0624c94dd8778318d427912bea733cb5.pngAs you can see, the GUI model is just invisible and the handheld model is a missing texture placeholder. 

I don't know what is wrong.

 

I already registered my custom ModelLoader class.

Also did ModelBakery.registerItemVariants(...)

and registered both models in the ModelLoader.setCustomModelResourceLocation(...)

 

Also the log doesn't return any error.

Edited by DeathSpawn
log
Link to comment
Share on other sites

No, sorry but my gradle.properties is the same as the one on my local machine.

 

My local machine's:

# Sets default memory used for gradle commands. Can be overridden by user or command line properties.
# This is required to provide enough memory for the Minecraft decompilation process.
org.gradle.jvmargs=-Xmx3G

 

Link to comment
Share on other sites

I've moved the ModelBakery.registerItemVariants to the ModelRegistryEvent but still the problem stays. I've tested the models without the custom ModelLoader and it works. But when it loads through the custom ModelLoader, it just doesn't seem to want to work. It shows the same result.

The problem persists. 

 

Also, Is using ModelBakery.registerItemVariants enough for the JSON models have to be loaded and baked by Minecraft or does it still go to the Custom ModelLoader somehow?

 

I've removed the second ModelLoader.setCustomModelResourceLocation. I finally understood what you meant by "location".

 

Please guide me if I have done something wrong.

Edited by DeathSpawn
questions and dumb
Link to comment
Share on other sites

For people of the future refering to this thread, follow the thread in the first post here. Then follow the below part if you got the same error I did.

 

In the ModelBakery.registerItemVariants, pass all the models you need for the perspective based model,

then, in the ModelLoader.setCustomModelResourceLocation, pass a dummy third model.

 

In the custom ICustomModelLoader class, make sure that your dummy third model gets passed through the loader rather than the models which you provided (which is what I did wrong) through ICustomModelLoader#accepts().

 

Make sure the ModelBakery and ModelLoader functions are happening in the ModelRegistryEvent.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.