Jump to content

1.12.2 Not supported anymore?


Recommended Posts

I know this has already been answered for the forum itself, but why can't we use 1.12.2 anymore client side??  Most servers STILL run on this version. I STILL play this version, or well... at least I did. Until I found out my installation for 1.12.2 is no longer there, and installing it does not work, meaning, I can't choose a profile, I can't create a new profile, and anyone complaining about it, their thread gets locked. I see no knowledge thread about the dropping of 1.12 client side. You STILL have it downloadable on the forge site. So, if you're not officially supporting it, why not remove ALL older version and keep only 1.13+? There are so many mods that I like that have not, and most likely wont be updated to 1.15+. Some of the modders refuse to update those 1.12.2 mods to 1.15. Of course, that's their choice in the matter. But dropping total support even client side is ridiculous since 90% of the player base plays 1.12.2. 

Please, spare me the "We don't support 1.12" comment. Just lock and save your time if you don't want to answer legit questions. Thank you! 

Edit: Considering I didn't realize I didn't have the forge installation anymore, my entire world has been corrupted that I spent 2 years on, with new lands, Biomes o plenty, vampire dark forest stuff, everything is now just gone with a lot of floating blocks from vanilla. My entire buildings are gone, my entire tamed animals are gone, everything I worked hard for. Gone....

2020-01-25 (1).png

Edited by Darkmage4
Link to comment
Share on other sites

2 minutes ago, diesieben07 said:

Forge has limited manpower.

A vote was held for the "LTS" version, 1.14.4 was chosen. So that version will be supported in addition to the latest one.

You can read more here:


I figured since this was client side, it wouldn't of mattered? So worlds are destroyed because forge is no longer supported and removed from profiles? I edited but I'll re-comment it: "Considering I didn't realize I didn't have the forge installation anymore, my entire world has been corrupted that I spent 2 years on, with new lands, Biomes o plenty, vampire dark forest stuff, everything is now just gone with a lot of floating blocks from vanilla. My entire buildings are gone, my entire tamed animals are gone, everything I worked hard for. Gone...."

Link to comment
Share on other sites

Just now, diesieben07 said:

Forge does not deliberately brick old versions. The old versions work just fine still, they just will no longer receive updates or support on this forum.

Minecraft worlds do get corrupted, that is completely unrelated to Forge dropping support for old versions. Regular backups are a necessity.

Well, something went awry, because I no longer have the installation I had a few months back, nothing was removed, I haven't even touched past 1.13, so I don't even have 1.14 or 1.15 vanilla installed yet. I tried to re-install, says it was successful. But as you can see the screen cap above, it's not there. It's in .minecraft/versions folder for 1.12.2 But it no longer shows in profiles or when creating a new installation. I do have a back up but that was months before. I stopped playing there for a bit, and that one has before i spent a good chunk working on a Vampire castle. 

The world didn't corrupt because of Forge, it corrupted because the wrong profile was loaded in and I hadn't realized this, went back I loaded in with 1.12.2 optifine instead of forge, looking for forge except 1.9. That's still there. But 1.12.2, no longer there. Vanished. 

Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Wait guys, I still don't don't understand... I shall send my code -- Define the function to decrease hunger local function decreaseHunger(player)     local currentHunger = player.getHunger()          -- Check if hunger is not already zero     if currentHunger > 0 then         player.setHunger(currentHunger - 1)     end end -- Register event to decrease hunger over time script.registerEvent(EntityPlayer, function(player)     while true do         -- Decrease hunger every few seconds         decreaseHunger(player)         script.sleep(1000) -- Sleep for 1 second     end end)     Any help appriecated. It's been a while since I learnt Javascript or whatever Minecraft is made with... ... ... ... Nicknotname Hungerinpeaceful xx
    • good days  i get this error: java.lang.ClassCastException: class net.minecraft.client.player.LocalPlayer cannot be cast to class net.minecraftforge.common.extensions.IForgeServerPlayer (net.minecraft.client.player.LocalPlayer is in module minecraft@1.20.4 of loader 'TRANSFORMER' @3e8b3b79; net.minecraftforge.common.extensions.IForgeServerPlayer is in module forge@49.0.26 of loader 'TRANSFORMER' @3e8b3b79)     at mercmod.blocks.classes.panel_whit_entity_inside.use(panel_whit_entity_inside.java:576) ~[main/:?] {re:classloading}     at net.minecraft.world.level.block.state.BlockBehaviour$BlockStateBase.use(BlockBehaviour.java:826) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading}     at net.minecraft.client.multiplayer.MultiPlayerGameMode.performUseItemOn(MultiPlayerGameMode.java:324) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraft.client.multiplayer.MultiPlayerGameMode.lambda$useItemOn$4(MultiPlayerGameMode.java:292) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraft.client.multiplayer.MultiPlayerGameMode.startPrediction(MultiPlayerGameMode.java:251) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraft.client.multiplayer.MultiPlayerGameMode.useItemOn(MultiPlayerGameMode.java:291) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.startUseItem(Minecraft.java:1799) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.handleKeybinds(Minecraft.java:2083) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.tick(Minecraft.java:1902) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.runTick(Minecraft.java:1216) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}     at net.minecraft.client.Minecraft.run(Minecraft.java:801) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}     at net.minecraft.client.main.Main.main(Main.java:234) ~[forge-1.20.4-49.0.26_mapped_official_1.20.4-recomp.jar:?] {re:classloading,pl:runtimedistcleaner:A} ------------------------------------------------------------------------------------------------------------------   context:  im updating the briefcase from mi mod an i need to make a gui whit this image that gonna be launched from a block and from a item soo im using kapenjoe tutorials  ---------------------------------------------------------------------------------------- The problem is that tutorial is for 1.20.1 and im using 1.20.4 and i really dont get how to call and open the gui from the block nor from the item i made this based on post i made short ago everything seems find but when right click the block to open the gui it crash the game  @Override public InteractionResult use(BlockState blkstate, Level warudo, BlockPos pos, Player pe, InteractionHand hand, BlockHitResult hitresult) {     if(warudo.isClientSide()){         BlockEntity blkentity = warudo.getBlockEntity(pos);         if(blkentity instanceof Panel_BlockEntity){             //   ↓↓↓  open the menu from the block              IForgeServerPlayer ifpe = (IForgeServerPlayer)pe; //<--- this is wrong  "class net.minecraft.client.player.LocalPlayer cannot be cast to class net.minecraftforge.common.extensions.IForgeServerPlayer"             ifpe.openMenu( (Panel_BlockEntity) blkentity, pos ); //<-- i need an example of how open a gui in 1.20.4         }     } return InteractionResult.sidedSuccess(warudo.isClientSide()); } Theres nothing highlighted in red in the code like everything where right an possible but dont works  ####################################################################################################### i need to see an example, just the piece of code for the use() method of the block whit the block entity for 1.20.4  and the same  but for the item     @Override     public @NotNull InteractionResultHolder<ItemStack> use(@NotNull Level warudo, @NotNull Player pe, @NotNull InteractionHand interactionHand)     {         if (!warudo.isClientSide())         {             ItemStack heldItem = pe.getItemInHand(interactionHand);                          if (heldItem.getCapability(ForgeCapabilities.ITEM_HANDLER).isPresent())             {                 //   ↓↓↓  open the menu from the item                 NetworkHooks.openScreen((ServerPlayer) pe, this);             }         }         return super.use(warudo, pe, interactionHand);     }   thanks for your attention           
    • It depends on the data you want to save, but generally speaking you should use some custom Player Capabilities, attach to the Player and use them to store/retrieve any kind of data you want. You can find how to make them work for 1.20.x in the documentation here: https://docs.minecraftforge.net/en/latest/datastorage/capabilities/
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.