Jump to content

Can't save world after using worldedit /regen on bigger area


Recommended Posts

After long time I came back after to my world - pre-aquatic 1.12.2 with forge (size about 1,5GB), very old with a lot of bioms discovered (a lot of chunks). I didn't upgrade it to aquatic that time, was waiting to get maybe some mod to convert it to higher and lost interest.


Yesterday I came back to minecraft and upgraded laucher, forge, wordedit to 1.15.2, java also, opened world (yes, I've got backup) in 1.15.2 and everything was ok (despite missing concrete blocks, but it's normal). I do not change procesor or graphic card since then, just added a litte bit of ram.

I also optimalized save - so I've go 2 versions - 1.12.2 opened in 1.15.2 and 1.12.2 optimalized to 1.15.2. (kill me but I don't see difference between them...)

I wanted to regenerate some chunks near base and regenerate some chunks in natural spawn village nearby to get seaweed or maybe other new things.

I used wordedit //chunk //regen on river/sea/plain biome - 1 chunk regen at time - and it was ok - new seeweed, fish, dolphins. Can save and exit. Works also, when I do it a few times, manually regen 1 chunk after another.

I tried to regen more than 1 chunk at time and selected few chunks at the time in river , sea, plain  - it was ok, regen works. Can save and exit.


I tried regen 1 chunk near village - yes, regen works. But the world freezes: In some places there are black unlit blocks, water don't move, villagers, animals do not move, I can't clik them, I can put torch/block on the ground. I can type //chunk, but it doesn't select next chunk. Console don't work BUT the sun moves. And I can't save game, game is frozen on brown save screen, I can't even close the window. After killing java it manually from manager game rolls back to previous state, before regen.  (uploaded file: latest - 2 chunks)


Also I can regen full village - but again everything freezes, like above - there are places which are dark - I can put torch there,, I can put block, I can destroy block  - entities don't move. Can't save. game rolls back. (uploaded file: 2020-03-14-2 - few chunks selected,  plus screenshots. Plus Village regen.txt.

Also - my render distance is 12, so when game freezes my world shrinks to 12x12 square...


I'm not a very good at technical aspects or modding aspects of the game. Some time I set some things that worked, but now they don't. I'd be grateful I someone explain me what I should do or change to get them work again and not afraid that after regeneration random chunk/s I lost progress. (Of course there is an option to not use WE, but WE is sometimes very useful and I'm afraid, that it affects other functions...)  Maybe I'm to impatient and I should wait... few hours. And maybe I shoud give moar memory to some process.  But now I dont know where...



Specs: Windows 7 pro, intel i5-4450, GeForce GTX 960

Minecraft - 1.15.2









2020-03-14-2 - few chunks selected.txt latest - 2 chunks.txt village regen.txt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.