Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mod updater


Steve_from_Minecraft
 Share

Recommended Posts

Hi, I reciently got Minecraft for PC and I’m having a lot of fun with it, but one of the issues I noticed is that not all the mods are updated to the latest version of Minecraft, so I came up with the idea of a program that could update or downgrade the mods depending of the preferences of the user, so that the mod developers only need to program one version of the mod and the program should do the rest of the work, I hope you read this.

 

I will appreciate your feedback.

 

Thank you.

 

JSML

 

 

Link to comment
Share on other sites

That cool but let me answer you with another question: How would you go about implementing this?

Most likely you'll give up by the time that you realize each mods are vastly different both in structure and execution. If that's not enough then you somehow need to take into account that with the parts of forge changes per update. Just not possible in practice.

 

Edited by Delupara
clarification

When they say your code doesn't follow convention but ur edgy so u dont care

d-d-d-dab on them haterz

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Title says it all. Ive googled this for hours and i cant find anything :(
    • Hey! I keep getting this error when I start my own Minecraft server: (Also to note: I am not very knowledge on how Java works as my servers have almost never had any type of issue) 2021-10-23 18:47:36,993 main ERROR Error processing element Queue ([Appenders: null]): CLASS_NOT_FOUND 2021-10-23 18:47:37,041 main WARN Advanced terminal features are not available in this environment 2021-10-23 18:47:37,078 main ERROR Unable to locate appender "ServerGuiConsole" for logger config "root" ←[32m[18:47:37] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 31.2.50, --fml.mcpVersion, 20200515.085601, --fml.mcVersion, 1.15.2, --fml.forgeGroup, net.minecraftforge, nogui] ←[m←[32m[18:47:37] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 5.1.2+70+master.2845bb9 starting: java version 15.0.2 by Oracle Corporation ←[m←[1;31m[18:47:37] [main/FATAL] [ne.mi.fm.lo.FMLLoader/CORE]: Access Transformer library is missing, we need this to run ←[m←[1;31m[18:47:37] [main/ERROR] [cp.mo.mo.TransformationServiceDecorator/MODLAUNCHER]: Service failed to load fml cpw.mods.modlauncher.api.IncompatibleEnvironmentException: Missing AccessTransformer, cannot run         at net.minecraftforge.fml.loading.FMLLoader.lambda$onInitialLoad$1(FMLLoader.java:104) ~[forge2.jar:31.2] {}         at java.util.Optional.orElseThrow(Optional.java:401) ~[?:?] {}         at net.minecraftforge.fml.loading.FMLLoader.onInitialLoad(FMLLoader.java:102) ~[forge2.jar:31.2] {}         at net.minecraftforge.fml.loading.FMLServiceProvider.onLoad(FMLServiceProvider.java:122) ~[forge2.jar:31.2] {}         at cpw.mods.modlauncher.TransformationServiceDecorator.onLoad(TransformationServiceDecorator.java:53) ~[modlauncher-5.1.2.jar:?] {}         at cpw.mods.modlauncher.TransformationServicesHandler.lambda$loadTransformationServices$11(TransformationServicesHandler.java:131) ~[modlauncher-5.1.2.jar:?] {}         at java.util.HashMap$Values.forEach(HashMap.java:1067) [?:?] {}         at cpw.mods.modlauncher.TransformationServicesHandler.loadTransformationServices(TransformationServicesHandler.java:131) [modlauncher-5.1.2.jar:?] {}         at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:56) [modlauncher-5.1.2.jar:?] {}         at cpw.mods.modlauncher.Launcher.run(Launcher.java:75) [modlauncher-5.1.2.jar:?] {}         at cpw.mods.modlauncher.Launcher.main(Launcher.java:65) [modlauncher-5.1.2.jar:?] {}         at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [forge2.jar:?] {}         at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [forge2.jar:?] {}         at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) [forge2.jar:?] {} ←[m←[1;31m[18:47:37] [main/ERROR] [cp.mo.mo.TransformationServicesHandler/MODLAUNCHER]: Found 1 services that failed to load : [fml] ←[m←[32m[18:47:37] [main/INFO] [STDERR/]: [net.minecraftforge.server.ServerMain$Runner:runLauncher:65]: The server is missing critical libraries and cannot load. Please run the installer to correct this ←[m
    • Hi, I don't know much about Minecraft Mod programming, and I'm making a mod, I need to know how to scale the model from the adult version to the child version. I'm currently doing the mod itself by Mcreator, and modeling by Blockbench. The reproduction of this mob is done, the problem is, the child is the same size as the adult. At first I would use two different models for this animal, but researching a little, I found that there is a way to scale the model. I wanted to know how to do this. Here below is the code.  
    • When I try to load it. It starts up but none can join the server as the forge jar is corrupted some how. Believe it is a fault in the update.  
    • Sorry I didn’t explain it in much detail at first hopefully this will be much more easier to understand. I am running a 1.16.5 forge server with java 8 there is multiple errors which you can see in the paste bin right at the top. Not sure what is the problem with it I followed a YouTube video it worked for him but not for me I believe it is because it is not registering the main class which is coursing the forge not to work it has no mods at all.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.