Jump to content

1.15.2 Forge Stuck on Atlas Stitching/Mod Setup Looping


Recommended Posts

Recently I decided to get back into Minecraft, wanting to go for a semi-Minecraft+ kinda feel. I've added maybe 20-ish mods in total, not counting their dependencies, but it seems like launching the game sends it into a sort of bootloop. I am perpetually stuck on the Mojang loading screen with text appearing, something about Atlas Stitching for paintings, shield patterns, beds, particles, blocks and shulker chests, right after which Mod Setup: ENQUEUE IMC appears in blue and the process repeats itself, with a message saying that it's loading mod configs and going right back to set-up. The version of FML I have is 31.1.61.


I have no other mods loaded in the mods folder, I've even cleared the configs for the mods. I've tried allocating another 2 GB of RAM to the program, but that didn't help either. JEI was appearing often, so I tried removing it, still nothing. I went about removing and trying to start up the game without a few of the choice mods I thought could impact things, but still nothing. When I try to boot up Forge without any mods, it seems to work just fine. I've tried looking through the logs, but I couldn't make sense of it, so I will leave it to y'all more capable hands.


Thanks in advance!

latest: https://pastebin.com/WijVPRgA



Edit: It's getting late so apologies if I don't react too quickly. I thought, maybe it's one of the mods I have installed, so I tried removing them one by one and starting the game to see if it'd fix it, yet, still nothing. One last thing I'll try and do is install a past version of Forge, if that doesn't work, I'll try a fresh reinstall of Minecraft tomorrow. Assume that if I don't make another edit the new version didn't help much.

Edit 2: Looks like a reinstall did help me figure out something - user error. Two of my mods are for 1.14, and one of 'em's just plain ol' broken. After downloading the appropriate versions, this seems to have worked. Apologies for the confusion.

Edited by Nategore
Link to comment
Share on other sites

  • 5 months later...


Botany Pots

Storage Drawers


All 3 of these mods had errors just trying to start them

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.