Jump to content

java.lang.ExceptionInInitializerError when I use Javacord


Recommended Posts



I begin a little project to bin minecraft with discord.

I'm using javacord which I find pleasant with the syntax (https://github.com/Javacord/Javacord


When I run my project with intelliJ, (runClient) I have no problem. the bot connect itself and send some message.


When I jar my project, and ru my server with it, the discord bot don't run. and I have this error :


      at org.javacord.api.DiscordApiBuilder.<init>(DiscordApiBuilder.java:30)
      at com.winx.minescord.process.discord.BotCreation.create(BotCreation.java:15)
      at com.winx.minescord.Minescord.<init>(Minescord.java:55)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
      at java.lang.Class.newInstance(Class.java:442)
      at net.minecraftforge.fml.javafmlmod.FMLModContainer.constructMod(FMLModContainer.java:131)
      at java.util.function.Consumer.lambda$andThen$0(Consumer.java:65)
      at java.util.function.Consumer.lambda$andThen$0(Consumer.java:65)
      at net.minecraftforge.fml.ModContainer.transitionState(ModContainer.java:112)
      at net.minecraftforge.fml.ModList.lambda$null$10(ModList.java:134)
      at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
      at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1382)
      at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482)
      at java.util.stream.ForEachOps$ForEachTask.compute(ForEachOps.java:291)
      at java.util.concurrent.CountedCompleter.exec(CountedCompleter.java:731)
      at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
      at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
      at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
      at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)
Caused by: java.lang.IllegalStateException: No DelegateFactoryDelegate implementation was found!


I verified and I have those dependencies in my jar.


Maybe I do something wrong so here is my build.gradle.

here is my repo https://github.com/CharlesLgn/minescord  


If someone has any idea, I'll be glad to know it. thank you.


Edited by Nyphew
Link to comment
Share on other sites

2 hours ago, superminerJG said:

An ExceptionInInitializerError basically says an exception occured when assigning a static variable. Make sure the static variables' initializers don't produce exceptions.

I know that. When I run it on IDEA, I have no problem. it's when I jar it and put it on my server.


Edited by Nyphew
Link to comment
Share on other sites


12 hours ago, superminerJG said:

You need to build it using Gradle.

Through my cmd or ma IDE, I have the same error


I had a look in the service injectition because I never did it. 

If I understand It

for an interface                   com.foo.Bar

and an implemented class com.foo.impl.BarImpl,

I need create a file named com.foo.Bar in META-INF/services with a single line com.foo.impl.BarImpl


Here it's not my  code, it's a dependency but when I open my jar with winRar, I have the service file, the interface AND the implemented classes... ?



Edited by Nyphew
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.