Jump to content

Twitch will not launch mods


Marshen

Recommended Posts

Hello! I have been trying to figure this out for hours now and i decided its just best if I ask for help. Everytime i try to launch a mod through the twitch app I am met with this crash report... "Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=256m; support was removed in 8.0
Error: Could not find or load main class E"

 

I could really use help and please try to explain it as simple as possible and tell me how to fix this :( I am currently trying to play All the Mods 4.

 

Tysm!

Link to comment
Share on other sites

Oh pfft, I misread, my bad.

What's your full configuration with program/vm arguments? It's having trouble finding the main class, which is an issue I've never seen someone have before.

  • Like 1

I'm eager to learn and am prone to mistakes. Don't hesitate to tell me how I can improve.

Link to comment
Share on other sites

How do i find those? is it in the minecraft launcher?

 

This is what it says in the launcher log

 

[19:42:19 FATAL]: Fatal error launching game. Report this to http://bugs.mojang.com please!
java.io.FileNotFoundException: File '/Users/ellagoldberg/Twitch/Minecraft/Install/assets/indexes/1.15.json' does not exist
    at org.apache.commons.io.FileUtils.openInputStream(FileUtils.java:299) ~[launcher.jar:1.6.93]
    at org.apache.commons.io.FileUtils.readFileToString(FileUtils.java:1711) ~[launcher.jar:1.6.93]
    at net.minecraft.launcher.Launcher.cleanupOrphanedAssets(Launcher.java:298) ~[launcher.jar:1.6.93]
    at net.minecraft.launcher.Launcher.performCleanups(Launcher.java:540) ~[launcher.jar:1.6.93]
    at net.minecraft.launcher.game.MinecraftGameRunner.launchGame(MinecraftGameRunner.java:209) ~[launcher.jar:1.6.93]
    at com.mojang.launcher.game.runner.AbstractGameRunner.onDownloadJobFinished(AbstractGameRunner.java:186) [launcher.jar:1.6.93]
    at com.mojang.launcher.updater.download.DownloadJob.popAndDownload(DownloadJob.java:122) [launcher.jar:1.6.93]
    at com.mojang.launcher.updater.download.DownloadJob.access$000(DownloadJob.java:12) [launcher.jar:1.6.93]
    at com.mojang.launcher.updater.download.DownloadJob$1.run(DownloadJob.java:86) [launcher.jar:1.6.93]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_251]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_251]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_251]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_251]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_251]
[19:42:19 ERROR]: Game ended with bad state (exit code 1)
[19:42:19 INFO]: Ignoring visibility rule and showing launcher due to a game crash
[19:42:19 INFO]: Deleting /Users/ellagoldberg/Twitch/Minecraft/Install/versions/forge-28.2.4/forge-28.2.4-natives-28291594003820
 

 

Edited by Marshen
Link to comment
Share on other sites

I don't use the Twitch launcher so I'm kind of just winging it here. In your settings for the Twitch launcher, there should be a Minecraft section. Down at the bottom is where I believe the java settings are.

From the sounds of it, I'm skeptical that that's where the problem is, but it's worth checking.

Edit: Ooh, didn't see your stealth edit.

Edited by imacatlolol

I'm eager to learn and am prone to mistakes. Don't hesitate to tell me how I can improve.

Link to comment
Share on other sites

Wait i think i figured out the problem. I accidently typed "E" in the Additional Arguments of the java settings. Everytime i try to delete it i change the tab and go back and it is still there.

 

I dont know how to make it stay deleted

Edited by Marshen
Link to comment
Share on other sites

It sounds like there's multiple problems at this point, the error in your edited post is different from the one in your original post.

If you can't get the arguments to stick, look around for a "Repair Minecraft" button somewhere. I don't know where it is, might be on the modpack's page, probably in one of those "..." menus; it should at least fix the FileNotFoundException.

I'm eager to learn and am prone to mistakes. Don't hesitate to tell me how I can improve.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I had a similar issue to what you do above. Given this is an old post, you've probably sorted this now In my case, I had Java (JDK) 22 installed. After uninstalling that and installing 17.0.11 (having both installed gives the same error), then running the startserver.bat worked for me. I managed to get to the EULA section and then start my server correctly- I hope it helps anyone else who may have this issue!
    • Make a test with another Launcher like MultiMC, AT Launcher or Technic Launcher
    • I opened up Minecraft today for the first time in a month and whenever I try and play forge I get an error 1 message. I restarted my computer, tried reinstalling both Minecraft and Forge and have updated all of my drivers. Nothing seems to work so I'm stumped. I have absolutely no mods installed ATM so I have no idea what could be causing the problem. I hope yall are able to help.   DebugLog:   [19May2024 20:33:51.600] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, dmoy18, --version, 1.20.1-forge-47.2.0, --gameDir, C:\Users\dmoyf\AppData\Roaming\.minecraft, --assetsDir, C:\Users\dmoyf\AppData\Roaming\.minecraft\assets, --assetIndex, 5, --uuid, c083972cd92d4dd2894beb25b82ebe82, --accessToken, ????????, --clientId, MDljMzIwMjYtOTJiNS00YWUxLTk1M2EtN2ExMGExZWM0MDAw, --xuid, 2535417310772497, --userType, msa, --versionType, release, --quickPlayPath, C:\Users\dmoyf\AppData\Roaming\.minecraft\quickPlay\java\1716168829421.json, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412] [19May2024 20:33:51.604] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.8 by Microsoft; OS Windows 11 arch amd64 version 10.0 [19May2024 20:33:51.634] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [fmlclientdev,forgeclient,minecraft,forgegametestserverdev,fmlserveruserdev,fmlclient,fmldatauserdev,forgeserverdev,forgeserveruserdev,forgeclientdev,forgeclientuserdev,forgeserver,forgedatadev,fmlserver,fmlclientuserdev,fmlserverdev,forgedatauserdev,testharness,forgegametestserveruserdev] [19May2024 20:33:51.653] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : [srgtomcp] [19May2024 20:33:51.668] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [mixin,eventbus,slf4jfixer,object_holder_definalize,runtime_enum_extender,capability_token_subclass,accesstransformer,runtimedistcleaner] [19May2024 20:33:51.681] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services [19May2024 20:33:51.688] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\mods [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\config [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is C:\Users\dmoyf\AppData\Roaming\.minecraft\config\fml.toml
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.