Jump to content

[1.15.2] [Solved] Problem with Feature Registration


Budschie

Recommended Posts

Hello. Currently I have following problem: I register my Feature like this:

	public static final RegistryObject<TestFeature> TEST = FEATURES.register("test", () -> new TestFeature(NoFeatureConfig::deserialize));
	public static final DeferredRegister<Feature<?>> FEATURES = new DeferredRegister<>(ForgeRegistries.FEATURES, References.MODID);

And I attach the feature to a biome with the following code:

this.addFeature(Decoration.UNDERGROUND_ORES, Features.TEST.get().withConfiguration(IFeatureConfig.NO_FEATURE_CONFIG).withPlacement(placement));

But it keeps crashing because the biome registry event seems to be fired first. ("java.lang.NullPointerException: Registry Object not present.")

How can I fix that issue?

Link to comment
Share on other sites

  • Budschie changed the title to [1.15.2] [Solved] Problem with Feature Registration

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.