Jump to content

[Solved][1.15.2] Biomes not registering provoking ChunkGen error


Recommended Posts


I have an issue registering my biomes since I added the structure generation (how are those linked, I don't know as they don't share anything in common), and therefore when trying to join a dimension that requires theses biomes, the game crashes as the structure generation can't get  proper bounds.

Here's the gist, and here's my repo. I inspired myself from Valhelsia Structure mod to add my tower structure to my custom dims. But as I haven't changed anything about the biome registering, I don't get why they're not registered anymore.


I hope you'll be able to help me again for this project.

Thanks anyway !

Edited by Elsopeen
Link to comment
Share on other sites

So, I tried a bit to understand, and it seems it doesn't come from my biomes as they are in fact registered, but it comes from JigsawManager.REGISTRIES that holds a registry name "minecraft:empty".
My TowerPiece get registered correctly and added to the registries, but as Jigsaw prefers random, it appears that the "minecraft:empty" get chosen instead of my tower.
Is there a way to check where that "minecraft:empty" comes from, how to remove it or how to bypass the random property of Jigsaw ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.