Jump to content

[1.15.2] reobf Gradle task does not use shadowJar


twixthehero

Recommended Posts

I have a simple POC mod which includes some external dependencies into it. When I run the `shadowJar` task, I see the appropriate dependencies are relocated and packaged into the output at `build/libs/classloadtest-1.15.2-0.0.1-shadow.jar`.

 

However, when I run the `jar` task, the dependencies are not included in the output jar. I searched around a bit and found [1.14.4] Jar-In-Jar Dependency Extraction Not Working [SOLVED] which I didn't really see any big differences besides Minecraft version.

 

Did I mess up something with my configuration?

 

Here's my `build.gradle`:

buildscript {
    repositories {
        maven { url = 'https://files.minecraftforge.net/maven' }
        google()
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath group: 'net.minecraftforge.gradle', name: 'ForgeGradle', version: '3.+', changing: true
    }
}

plugins {
    id 'com.github.johnrengelman.shadow' version '4.0.4'
    id 'idea'
    id 'java'
    id 'maven-publish'
    id 'org.jetbrains.kotlin.jvm' version '1.3.72'
}

apply plugin: 'net.minecraftforge.gradle'

repositories {
    maven { url = 'https://files.minecraftforge.net/maven' }
    google()
    jcenter()
    mavenCentral()
}

...

configurations {
    shadow
    compile.extendsFrom shadow
}

def kotlinVersion = plugins.findPlugin('org.jetbrains.kotlin.jvm').kotlinPluginVersion
def exposedVersion = '0.25.1'

dependencies {
    shadow "org.jetbrains.kotlin:kotlin-stdlib-jdk8:${kotlinVersion}"

    shadow 'com.h2database:h2:1.4.200'
    shadow "org.jetbrains.exposed:exposed-core:${exposedVersion}"
    shadow "org.jetbrains.exposed:exposed-dao:${exposedVersion}"
    shadow "org.jetbrains.exposed:exposed-jdbc:${exposedVersion}"
    shadow "org.jetbrains.exposed:exposed-java-time:${exposedVersion}"

    minecraft 'net.minecraftforge:forge:1.15.2-31.2.9'
}

jar {
    manifest {
        attributes([
                'Specification-Title'     : 'Krythera Classload Test',
                'Specification-Vendor'    : 'krythera',
                'Specification-Version'   : '1', // We are version 1 of ourselves
                'Implementation-Title'    : project.name,
                'Implementation-Version'  : project.version,
                'Implementation-Vendor'   : 'krythera',
                'Implementation-Timestamp': new Date().format("yyyy-MM-dd'T'HH:mm:ssZ")
        ])
    }
}

shadowJar {
    classifier 'shadow'

    project.configurations.shadow.setTransitive(true)
    configurations = [project.configurations.shadow]

    relocate 'kotlin', 'com.krythera.shadow.kotlin'
    relocate 'kotlinx', 'com.krythera.shadow.kotlinx'
    relocate 'org.h2', 'com.krythera.shadow.org.h2'
    relocate 'org.intellij', 'com.krythera.shadow.org.intellij'
    relocate 'org.jetbrains', 'com.krythera.shadow.org.jetbrains'
    relocate 'org.slf4j', 'com.krythera.shadow.org.slf4j'
}

reobf {
    shadowJar {}
}

jar.finalizedBy('reobfJar')
// However if you are in a multi-project build, dev time needs unobfed jar files, so you can delay the obfuscation until publishing by doing
//publish.dependsOn('reobfJar')

artifacts {
    archives shadowJar
}

 

Edited by twixthehero
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.