Jump to content

[1.15.2] Help with tile entity registration


Flamabalistic

Recommended Posts

2 hours ago, Flamabalistic said:

I'm just starting out modding and I'm trying to make just a basic tile entity, however I'm getting an error "Cannot resolve constructor 'DarkFurnaceTileEntity'", below are my registry class and the aforementioned tile entity class, any ideas?
Tile entity: https://pastebin.com/Pzc54Jmh
Registry: https://pastebin.com/hBhRAS7U

The only difference I can see between your and mine code, that worked, is:

I deleted TileEntity(final TileEntityType<?> tileEntityTypeIn) constructor from my TE class. And then I used

super(TestMod.TEST_TILE_ENTITY_REGISTRY_OBJECT.get());

(in my case) in constructor with no arguments.

Everything said above may be absolutely wrong. No rights reserved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.