Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Server crashing. 1.16.1


TopNotchMC
 Share

Recommended Posts

I started a server yesterday. The server worked fine. I added a custom world, which is modded, the mod is installed both in my mods folder and the server folder. The server worked fine with the custom world. Today when I tried to lauch it, it didn't work. It turned on the cmd and then the white screen for 2 seconds before it closed. I created a second server with the same mods and it worked, later when I pasted in the server.properties it didn't work same thing happend as before. I created a new server again and i pasted the world foler. Tried to launch the server, but it did the same thing. I have tried for 5 hours now and I feel like I have checked the whole internet! These are the chrash logs and the server properties:

 

---- Minecraft Crash Report ----
// You should try our sister game, Minceraft!

Time: 2020-09-13 17:48
Description: Exception in server tick loop

com.electronwill.nightconfig.core.io.ParsingException: Not enough data available
    at com.electronwill.nightconfig.core.io.ParsingException.notEnoughData(ParsingException.java:22) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.ReaderInput.directReadChar(ReaderInput.java:36) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.AbstractInput.readChar(AbstractInput.java:49) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.AbstractInput.readCharsUntil(AbstractInput.java:123) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.toml.TableParser.parseKey(TableParser.java:166) ~[toml-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.toml.TableParser.parseDottedKey(TableParser.java:145) ~[toml-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.toml.TableParser.parseNormal(TableParser.java:55) ~[toml-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.toml.TomlParser.parse(TomlParser.java:44) ~[toml-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.toml.TomlParser.parse(TomlParser.java:37) ~[toml-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:113) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:219) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.io.ConfigParser.parse(ConfigParser.java:202) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.file.WriteSyncFileConfig.load(WriteSyncFileConfig.java:73) ~[core-3.6.2.jar:?] {}
    at com.electronwill.nightconfig.core.file.AutosaveCommentedFileConfig.load(AutosaveCommentedFileConfig.java:85) ~[core-3.6.2.jar:?] {}
    at net.minecraftforge.fml.config.ConfigFileTypeHandler.lambda$reader$1(ConfigFileTypeHandler.java:53) ~[?:?] {re:classloading}
    at net.minecraftforge.fml.config.ConfigTracker.openConfig(ConfigTracker.java:104) ~[?:?] {re:classloading}
    at net.minecraftforge.fml.config.ConfigTracker.lambda$loadConfigs$1(ConfigTracker.java:83) ~[?:?] {re:classloading}
    at java.lang.Iterable.forEach(Unknown Source) ~[?:1.8.0_261] {}
    at java.util.Collections$SynchronizedCollection.forEach(Unknown Source) ~[?:1.8.0_261] {}
    at net.minecraftforge.fml.config.ConfigTracker.loadConfigs(ConfigTracker.java:83) ~[?:?] {re:classloading}
    at net.minecraftforge.fml.server.ServerLifecycleHooks.handleServerAboutToStart(ServerLifecycleHooks.java:97) ~[?:?] {re:classloading}
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:163) ~[?:?] {re:classloading,pl:accesstransformer:B}
    at net.minecraft.server.MinecraftServer.func_240802_v_(MinecraftServer.java:622) ~[?:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}
    at net.minecraft.server.MinecraftServer.lambda$func_240784_a_$0(MinecraftServer.java:230) ~[?:?] {re:classloading,pl:accesstransformer:B,pl:runtimedistcleaner:A}
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_261] {}


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.16.1
    Minecraft Version ID: 1.16.1
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_261, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 8206983888 bytes (7826 MB) / 10345250816 bytes (9866 MB) up to 10345250816 bytes (9866 MB)
    CPUs: 8
    JVM Flags: 2 total; -Xmx10096M -Xms10096M
    ModLauncher: 6.1.1+74+master.966c698
    ModLauncher launch target: fmlserver
    ModLauncher naming: srg
    ModLauncher services: 
        /mixin-0.8.jar mixin PLUGINSERVICE 
        /eventbus-3.0.3-service.jar eventbus PLUGINSERVICE 
        /forge-1.16.1-32.0.108.jar object_holder_definalize PLUGINSERVICE 
        /forge-1.16.1-32.0.108.jar runtime_enum_extender PLUGINSERVICE 
        /accesstransformers-2.2.0-shadowed.jar accesstransformer PLUGINSERVICE 
        /forge-1.16.1-32.0.108.jar capability_inject_definalize PLUGINSERVICE 
        /forge-1.16.1-32.0.108.jar runtimedistcleaner PLUGINSERVICE 
        /mixin-0.8.jar mixin TRANSFORMATIONSERVICE 
        /forge-1.16.1-32.0.108.jar fml TRANSFORMATIONSERVICE 
    FML: 32.0
    Forge: net.minecraftforge:32.0.108
    FML Language Providers: 
        javafml@32.0
        minecraft@1
    Mod List: 
        forge-1.16.1-32.0.108-server.jar Minecraft {minecraft@1.16.1 DONE}
        Falling-Tree-Mod-1.16.1.jar Falling Tree {falling_tree@2.2.1 DONE}
        backpacked-1.5.1-1.16.1.jar Backpacked {backpacked@1.5.1 DONE}
        forge-1.16.1-32.0.108-universal.jar Forge {forge@32.0.108 DONE}
        BiomesOPlenty-1.16.1-11.0.0.395-universal.jar Biomes O' Plenty {biomesoplenty@1.16.1-11.0.0.395 DONE}
        Xaeros-Minimap-Mod-1.16.1.jar Xaero's Minimap {xaerominimap@20.17.0 DONE}
        cfm-7.0.0-pre18-mc1.16.1.jar MrCrayfish's Furniture Mod {cfm@7.0.0-pre18 DONE}
        Cooking-for-Blockheads-Mod-1.16.1.jar Cooking for Blockheads {cookingforblockheads@9.0.2 DONE}
        jei-1.16.1-7.0.0.2.jar Just Enough Items {jei@7.0.0.2 DONE}
    Player Count: 0 / 20; []
    Data Packs: vanilla, mod:falling_tree, mod:backpacked, mod:forge, mod:biomesoplenty, mod:xaerominimap, mod:cfm, mod:cookingforblockheads (incompatible), mod:jei (incompatible)
    Is Modded: Definitely; Server brand changed to 'forge'
    Type: Dedicated Server (map_server.txt)

 

 

 

The server properties:

 

#Minecraft server properties
#Sun Sep 13 17:48:20 CEST 2020
allow-flight=false
allow-nether=true
broadcast-console-to-ops=true
broadcast-rcon-to-ops=true
difficulty=easy
enable-command-block=false
enable-jmx-monitoring=false
enable-query=false
enable-rcon=false
enable-status=true
enforce-whitelist=false
entity-broadcast-range-percentage=100
force-gamemode=false
function-permission-level=2
gamemode=survival
generate-structures=true
generator-settings=
hardcore=false
level-name=ServerWorld
level-seed=
level-type=default
max-build-height=256
max-players=20
max-tick-time=60000
max-world-size=29999984
motd=A Minecraft Server
network-compression-threshold=256
online-mode=true
op-permission-level=4
player-idle-timeout=0
prevent-proxy-connections=false
pvp=true
query.port=
rcon.password=
rcon.port=
resource-pack=
resource-pack-sha1=
server-ip=
server-port=
snooper-enabled=true
spawn-animals=true
spawn-monsters=true
spawn-npcs=true
spawn-protection=16
sync-chunk-writes=true
use-native-transport=true
view-distance=10
white-list=false
 

 

I removed the ports because idk if it is sensitive info. The level-name has the same name as the world folder.

Edited by TopNotchMC
Link to comment
Share on other sites

First, some of your mods appear to be from, repost sites.

Please check out StopModReposts

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.