Jump to content

[1.16.3] Joining the game mounted on a horse


Recommended Posts


Spent all day trying to figure out why my code worked on 1.14.4 and 1.15.2 but was having a problem on 1.16.3.
So I started some testing....Using [1.16.3-34.1.0] then [1.16.3-34.1.23] and eventually [1.16.3] Vanilla and the problem continued across the board.

Create new single player world.
Spawn in a horse, tame it and ride it [or just find one].
Log out while still on the horse and quit the game.
Restart the game and log back into the world.
You will fall off/through the horse as you load in, but you are not really off the horse, even though you can move around.
When you press the shift key you will be dismounted and standing beside the horse.

Headed off to figure out how to report the problem now, hope this saves someone a headache, including lex.

Edited by frakier
Link to comment
Share on other sites

  • frakier changed the title to [1.16.3] NOT FORGE PROBLEM Joining the game mounted on a horse

OK, cannot get it to do this today. Next time I will restart the computer and the game to see what happens. Funny thing is when it was happening I tried the same test with both 1.14.4 vanilla and 1.15.2 vanilla without any problems. And when I started 1.16.3 vanilla back up it happened again. Going to write it off as a weird glitch for now.  But I will keep my eyes open for it to happen again. Let Minecraft know that I could not reproduce this morning, they wanted a video which I cannot do, but I was going to see if I could get some screen shots.
But it all worked just fine, who knows, like I said though I will restart next time something weird like that happens before i spend all day trying to diagnose the problem.

Edited by frakier
Link to comment
Share on other sites

  • frakier changed the title to [1.16.3] Joining the game mounted on a horse

So new information...
Since I could not get the error today in the vanilla world I wrote it off as a glitch.
Went into my code in eclipse and ran my mod and the glitch/error/whatever was there I fell through the horse.
So I went back into the Minecraft Launcher, I ran the vanilla world to do the test and it happens there as well.

How can there be cross contamination, Minrcreaft Launcher puts the world save in AppData\Roaming\.minecraft.

{though of anther test, be right back}

So whats going on? How can two unrelated programs do the same thing? I can't understand unless the problem is inherit to 1.16.3 Vanilla.



Edited by frakier
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.